New IMRC Actuator Still Get Code P1518 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-17-2012, 09:31 PM   #1
AlfPrev
Focus Jr. Enthusiast
 
Join Date: Sep 2012
Fan#: 104347
Location: town, ND
What I Drive: car

Posts: 25
FF Reputation: 1 AlfPrev Good Standing Member
Buy-Sell-Trade Rating: (0)
New IMRC Actuator Still Get Code P1518

Hey everyone, this is my first post. Great site, tons of info on here.

I've searched for this, but I can't find anything like what I'm experiencing. I had two codes for oxygen sensors and IMRC stuck open. I fixed the O2 sensors and tried to fix the IMRC box, but my light stayed on and the car runs like crap. So I ordered a new actuator from Tousley Ford, put it on, and it still doesn't work. The cable does not move, I even unplugged the connector while it was running to see if it would open, but it already was open. Is there a fuse for this or anything else I should look for? I'm running out of patience.


AlfPrev is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2012, 08:58 AM   #2
Sonic 03 SVT
Focus Enthusiast
 
Sonic 03 SVT's Avatar
 
Join Date: Oct 2012
Fan#: 104471
Location: Livonia, MI
What I Drive: '03 Sonic Blue SVTF ZX3

Posts: 130
FF Reputation: 1 Sonic 03 SVT Good Standing Member
Buy-Sell-Trade Rating: (2)
Hi AlfPrev, welcome to the site. I had the same codes on my car when I purchased it. I had the IMRC stuck open, I took the box out and opened it up and did a repair the I found on this site. Link- http://www.focusfanatics.com/forum/showthread.php?t=222180 If your not getting any power to it, take a voltmeter to the connector that goes to the IMRC box and test for power. As for a fuse, it should be fuse #10 on under your dash. Let me know if any of this helps.
__________________
-1999 Mustang GT 5 speed- Mild Mods-SOLD
-1994 Exploder Winter Beater-SOLD
-2003 Sonic Blue SVTF ZX3 Build #800 of 3,985. -SOLD
-1998 Mark VIII LSC Collectors Edition #592
-2001 Mustang GT 5 Speed
Sonic 03 SVT is offline  
    Reply With Quote
Old 10-19-2012, 11:07 AM   #3
AlfPrev
Focus Jr. Enthusiast
 
Join Date: Sep 2012
Fan#: 104347
Location: town, ND
What I Drive: car

Posts: 25
FF Reputation: 1 AlfPrev Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks for the reply. I did open two boxes and do the repair and it did not fix the problem. I just checked every fuse in the car and I did not find any bad ones. I had someone start the car for me while I looked at the cable and it does pull initially, but then let's go after a few seconds. Everything I've read says it should stay pulled until 6000 rpms. I read another thread that states it could be the idle valve, I have no idea what or where this is. I also checked the IMRC plug for power with a test light while it was running and two wires have power. I swear I read somewhere that someone had a problem with it working initially and the opening, but I can't find that thread now.
AlfPrev is offline  
    Reply With Quote
Old 10-19-2012, 06:57 PM   #4
Sonic 03 SVT
Focus Enthusiast
 
Sonic 03 SVT's Avatar
 
Join Date: Oct 2012
Fan#: 104471
Location: Livonia, MI
What I Drive: '03 Sonic Blue SVTF ZX3

Posts: 130
FF Reputation: 1 Sonic 03 SVT Good Standing Member
Buy-Sell-Trade Rating: (2)
The idle valve im assuming your refering to the Idle Air Control Valve (IAC). The IAC basicly controls the cars idle, and when your rev your engine, it allows the engine to slowly rev down. Here is a link to a thread here on focus fanatics that shows you the location and how to clean your IAC. Keep me posted on your progress.
__________________
-1999 Mustang GT 5 speed- Mild Mods-SOLD
-1994 Exploder Winter Beater-SOLD
-2003 Sonic Blue SVTF ZX3 Build #800 of 3,985. -SOLD
-1998 Mark VIII LSC Collectors Edition #592
-2001 Mustang GT 5 Speed
Sonic 03 SVT is offline  
    Reply With Quote
Old 10-20-2012, 11:54 AM   #5
FLYLOW
Focus Fanatic
 
FLYLOW's Avatar
 
Join Date: Apr 2006
Fan#: 34077
Location: Houston, TX
What I Drive: Gen Coupe Rspec

Posts: 1,794
FF Reputation: 4 FLYLOW Good Standing Member
Buy-Sell-Trade Rating: (7)
whats the specific IMRC fuse number and location spot?

EDIT: took me 2 seconds on google. Location #18? but they said under the hood not under the dash
FLYLOW is offline  
    Reply With Quote
Old 10-20-2012, 12:40 PM   #6
AlfPrev
Focus Jr. Enthusiast
 
Join Date: Sep 2012
Fan#: 104347
Location: town, ND
What I Drive: car

Posts: 25
FF Reputation: 1 AlfPrev Good Standing Member
Buy-Sell-Trade Rating: (0)
I'm still trying to figure this problem out. I cleaned all the ground wires I could find except one that's so rusty the bolt is stuck( got pb blaster on it). I also cleaned the MAF and I removed the IAC and cleaned it, I also cleaned the throttle body which was gummed up. I took it for a ride and it does run better. Smoother idle and more low RPM power, but the IMRC is still not actuating and I still have a CEL.

As far as which fuse the IMRC is I don't think it's #18. I'm pretty sure that's the heated O2 sensor fuse.
AlfPrev is offline  
    Reply With Quote
Old 10-20-2012, 04:17 PM   #7
FLYLOW
Focus Fanatic
 
FLYLOW's Avatar
 
Join Date: Apr 2006
Fan#: 34077
Location: Houston, TX
What I Drive: Gen Coupe Rspec

Posts: 1,794
FF Reputation: 4 FLYLOW Good Standing Member
Buy-Sell-Trade Rating: (7)
Quote:
Originally Posted by AlfPrev View Post
I'm still trying to figure this problem out. I cleaned all the ground wires I could find except one that's so rusty the bolt is stuck( got pb blaster on it). I also cleaned the MAF and I removed the IAC and cleaned it, I also cleaned the throttle body which was gummed up. I took it for a ride and it does run better. Smoother idle and more low RPM power, but the IMRC is still not actuating and I still have a CEL.

As far as which fuse the IMRC is I don't think it's #18. I'm pretty sure that's the heated O2 sensor fuse.
crap well got that info from a thread here...

anyone know what number is it??? is it under dash or under hood???
FLYLOW is offline  
    Reply With Quote
Old 10-29-2012, 08:27 PM   #8
AlfPrev
Focus Jr. Enthusiast
 
Join Date: Sep 2012
Fan#: 104347
Location: town, ND
What I Drive: car

Posts: 25
FF Reputation: 1 AlfPrev Good Standing Member
Buy-Sell-Trade Rating: (0)
Bump. I'm still having this problem. IMRC actuates upon start up, then deactivates a few seconds later. I have a CEL and getting code P1518 IMRC stuck open. I was able to remove the ground cable on the engine after heating the bolt, it was badly corroded. I cleaned it and reassembled, but the light is still on and I can see it is not working correctly. Someone has to have had this problem before, any more suggestions? Thanks
AlfPrev is offline  
    Reply With Quote
Old 10-30-2012, 06:11 PM   #9
z28forlife
Focus Enthusiast
 
Join Date: Jul 2009
Fan#: 67288
Location: Atlanta, GA
What I Drive: 2003 Silver EAP SVT Focus

Posts: 149
FF Reputation: 1 z28forlife Good Standing Member
Buy-Sell-Trade Rating: (0)
Are you sure the imrc is getting power?
z28forlife is offline  
    Reply With Quote
Old 10-30-2012, 07:01 PM   #10
AlfPrev
Focus Jr. Enthusiast
 
Join Date: Sep 2012
Fan#: 104347
Location: town, ND
What I Drive: car

Posts: 25
FF Reputation: 1 AlfPrev Good Standing Member
Buy-Sell-Trade Rating: (0)
Yeah I checked with a multi meter. I'm getting 12 volts from two wires and about 2 volts from one, the other two are grounds. This is with the key to the run position and with the car running. Also tried another actuator and it does the same thing.
AlfPrev is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:06 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.