Is this normal? rpms seem to hang - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-06-2012, 03:25 PM   #1
perkgana
Focus Rookie
 
Join Date: Sep 2012
Fan#: 104279
Location: Salt Lake City, United States
What I Drive: 2000 grey zx3

Posts: 17
FF Reputation: 1 perkgana Good Standing Member
Buy-Sell-Trade Rating: (0)
Is this normal? rpms seem to hang

So I've been riding a lot about this and I cant find a satisfying answer.

Watch the video.

http://youtu.be/541eya3QYqc

The car is already warm. when you rev it the engine revs up and down normally but hangs at abour 1200 rpms for a WHILE and then drops down to 800 (normal) is that normal? This is my first used zx3

Also when I am driving, lets say I want to come to a complete stop so I let off the throttle for a while watch the engine rev down a few hundred rpms and then when I press the clutch to shift out of gear it revs up on its own.. about 200-400 rpms.

Also when I let off the throttle to use the engine to slow down it seems to hang at 2000 rpms for a loooong time.

Are this issues normal on a ZX3 ???? (2000 with 90k miles)

If something is wrong, any idea what? I tried finding vacuum leaks but no luck and I used seafoam to see if that helps and nothing either. Cleaned the Throttle body too (which was nasty).

Thanks!!!!


perkgana is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2012, 09:20 PM   #2
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, Ohio, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,312
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat".
__________________
zetecDon is offline  
    Reply With Quote
Old 10-07-2012, 11:46 AM   #3
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,066
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
You could clean the IAC, but it might be normal. This fuel system is designed to hold rpms when shifting. When you shift into N going downhill, the ECU sees a VSS signal, and maintains a higher rpm because that helps you shift into gears. Once you stop, it waits a few, then drops the idle to N speed.

Letting off the gas going downhill--- um, the idle will stay up then because the car is in gear. Fuel is cut off, but the engine will spin at the same speed because the wheels are turning the engine.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote
Old 10-07-2012, 11:49 AM   #4
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,066
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
I'd also consider an A/F reset: Remove negative battery terminal for 10 mins or so, then reconnect. Start engine, do not touch accelerator. Engine idle will be slightly high, and will fluctuate. The ECU will time a test 5 minutes after the engine drops out of cold-start mode. What you'll see is idle up to about 1500, then drop and stay around 1000 rpm. At the end of the test, idle will drop to 700. Now the A/F is set. Wait about 6-7 mins, and listen or check the tach for the drop.

Common vacuum leaks include the PCV vacuum line. You should be able to find a ton of information on that on here because it causes many problems in older Zetecs. Depending on how it goes bad it can cause a high or low idle.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote
Old 10-07-2012, 01:02 PM   #5
perkgana
Focus Rookie
 
Join Date: Sep 2012
Fan#: 104279
Location: Salt Lake City, United States
What I Drive: 2000 grey zx3

Posts: 17
FF Reputation: 1 perkgana Good Standing Member
Buy-Sell-Trade Rating: (0)
I never said I was going downhill. This happens on a flat road.

I did an experiment yesterday. While driving in 3rd gear at about 3k rpms I let off the throttle and shifted to neutral. The engine stayed at 3000 rpms for a LONG time while I coasted down the road. Finally after about a block coasting I braked and once I got to about under 10 mph the rpms started dropping to about 1200.Weird!

I've read something about "Throttle body resonance" which seemed to be a problem and caused a recall.
perkgana is offline  
    Reply With Quote
Old 10-07-2012, 01:10 PM   #6
sailor
"Elder"
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 11,663
FF Reputation: 60 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Commented on your other posting...
sailor is offline  
    Reply With Quote
Old 10-07-2012, 01:12 PM   #7
perkgana
Focus Rookie
 
Join Date: Sep 2012
Fan#: 104279
Location: Salt Lake City, United States
What I Drive: 2000 grey zx3

Posts: 17
FF Reputation: 1 perkgana Good Standing Member
Buy-Sell-Trade Rating: (0)
Cool! sorry was my first post and I guess I screwed it up! hahaha Posted twice I guess
perkgana is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:19 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.