Car randomly died, spedo and gadges stuck. - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus First Generation > MK1 Focus

MK1 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the first generation 2000-2007 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-05-2012, 07:40 PM   #1
HxCThumbs
Focus Enthusiast
 
HxCThumbs's Avatar
 
Join Date: Sep 2010
Fan#: 78852
Location: Salt Lake City, UT
What I Drive: 2005 White ZX4

Posts: 77
FF Reputation: 1 HxCThumbs Good Standing Member
Buy-Sell-Trade Rating: (0)
Exclamation Car randomly died, spedo and gadges stuck.

wont even turn over everything stuck like fuel gauges stuck and spedo help help new battery yesterday. wtf


__________________
I has focus
HxCThumbs is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2012, 12:38 AM   #2
Indy'sexclusiveZx3
Focus Addict
 
Join Date: May 2009
Fan#: 65419
Location: Indianapolis, IN
What I Drive: 2013 tuxedo black st

Posts: 569
FF Reputation: 7 Indy'sexclusiveZx3 Good Standing Member
Buy-Sell-Trade Rating: (3)
Recheck your battery connections
__________________
Parts for sale check out my thread, got a new st need to sale old parts
Indy'sexclusiveZx3 is offline  
    Reply With Quote
Old 10-07-2012, 10:18 PM   #3
HxCThumbs
Focus Enthusiast
 
HxCThumbs's Avatar
 
Join Date: Sep 2010
Fan#: 78852
Location: Salt Lake City, UT
What I Drive: 2005 White ZX4

Posts: 77
FF Reputation: 1 HxCThumbs Good Standing Member
Buy-Sell-Trade Rating: (0)
Not the problem. all connections are good. even with it getting jumped there are no lights at all like a blown fuse or something but all fuses look okay
__________________
I has focus
HxCThumbs is offline  
    Reply With Quote
Old 10-07-2012, 11:43 PM   #4
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,466
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
alternator ?
__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote
Old 10-12-2012, 04:07 PM   #5
focusonthefocus19
Focus Enthusiast
 
Join Date: Sep 2012
Fan#: 104272
Location: willis, TX
What I Drive: 2002 yellow focus zx3

Posts: 68
FF Reputation: 1 focusonthefocus19 Good Standing Member
Buy-Sell-Trade Rating: (0)
That happened to me when I replaced the battery. I got a little scared thinking I messed some thing up. I took off both of the battery cables, and put them on a few seconds later. It fixed it! Not a single problem since.
focusonthefocus19 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:01 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.