05' 2.3 ST with a few problems. Need guidance on where to begin... - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-28-2012, 07:54 PM   #1
bloostd
Focus Jr. Enthusiast
 
Join Date: Sep 2008
Fan#: 59310
Location: Washington, D.C., DC
What I Drive: 2005 Ford Focus ST Black

Posts: 38
FF Reputation: 1 bloostd Good Standing Member
Buy-Sell-Trade Rating: (1)
Arrow 05' 2.3 ST with a few problems. Need guidance on where to begin...

Hey Fellow Fanatics,

I've got some issues with my 05 ST I purchased almost a year ago... The same issues since I bought it with. Hell 60k miles, ST with heated seats, for 4500- salvaged title. Car looks completely fine and was fixed inappropriately. Great DD.

Anyways, When I turn on my headlights with out without fog/ parking lights, all my cluster instrument lights go out. If I play with it, putting pressure on it, and turning it, I can get the lights to stay on while in parking light mode- but when you turn fully to headlights- boom, the lights on the cluster gauge/ hvac all go dead.

Whats the deal? What do I need to do or buy?

Next thing,
The E-Brake handle spring-push-button broke. It won't say locked. What part do I actually need? Can i just replaced the spring or do I need the whole part? Which part would that be?

3rd issue, HVAC controls. The blower only works in the 3 position. The rest of them do not. I'm guessing its the control switch?

4thly, What kind of maintenance should I do at 75k mile interval? I've replaced the brakes, and changed the oil- thats about it.

Anything I need to worry about?

Thanks guys!

Have a great weekend.

Bret


__________________
2005 Focus ST
2004 Screaming Yellow Cobra, 2.8 Kenne Bell...slow
2006 Focus ST SAP- Sold
2004 EAP SVT Focus- sold
2003 DSG Cobra 2.3 Whipple Vert - Sold
bloostd is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 09-28-2012, 10:48 PM   #2
bloostd
Focus Jr. Enthusiast
 
Join Date: Sep 2008
Fan#: 59310
Location: Washington, D.C., DC
What I Drive: 2005 Ford Focus ST Black

Posts: 38
FF Reputation: 1 bloostd Good Standing Member
Buy-Sell-Trade Rating: (1)
Come on people, It's the weekend. Time to work on this ole' Daily Driver. Don't want to bring out the Screaming Yellow ^__^
__________________
2005 Focus ST
2004 Screaming Yellow Cobra, 2.8 Kenne Bell...slow
2006 Focus ST SAP- Sold
2004 EAP SVT Focus- sold
2003 DSG Cobra 2.3 Whipple Vert - Sold
bloostd is offline  
    Reply With Quote
Old 09-29-2012, 03:04 PM   #3
bloostd
Focus Jr. Enthusiast
 
Join Date: Sep 2008
Fan#: 59310
Location: Washington, D.C., DC
What I Drive: 2005 Ford Focus ST Black

Posts: 38
FF Reputation: 1 bloostd Good Standing Member
Buy-Sell-Trade Rating: (1)
any insight fellas?
__________________
2005 Focus ST
2004 Screaming Yellow Cobra, 2.8 Kenne Bell...slow
2006 Focus ST SAP- Sold
2004 EAP SVT Focus- sold
2003 DSG Cobra 2.3 Whipple Vert - Sold
bloostd is offline  
    Reply With Quote
Old 09-29-2012, 11:54 PM   #4
SilverST05
Focus Enthusiast
 
SilverST05's Avatar
 
Join Date: Aug 2012
Fan#: 103209
Location: Urbandale, IA
What I Drive: 2005 Silver Frost ST

Posts: 189
FF Reputation: 1 SilverST05 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by bloostd View Post
Hey Fellow Fanatics,

I've got some issues with my 05 ST I purchased almost a year ago... The same issues since I bought it with. Hell 60k miles, ST with heated seats, for 4500- salvaged title. Car looks completely fine and was fixed inappropriately. Great DD.

Anyways, When I turn on my headlights with out without fog/ parking lights, all my cluster instrument lights go out. If I play with it, putting pressure on it, and turning it, I can get the lights to stay on while in parking light mode- but when you turn fully to headlights- boom, the lights on the cluster gauge/ hvac all go dead.

Whats the deal? What do I need to do or buy?

Next thing,
The E-Brake handle spring-push-button broke. It won't say locked. What part do I actually need? Can i just replaced the spring or do I need the whole part? Which part would that be?

3rd issue, HVAC controls. The blower only works in the 3 position. The rest of them do not. I'm guessing its the control switch?

4thly, What kind of maintenance should I do at 75k mile interval? I've replaced the brakes, and changed the oil- thats about it.

Anything I need to worry about?

Thanks guys!

Have a great weekend.


Bret

First problem sounds like the headlight switch needs replaced.

The E brake thing, I have no idea never tore apart an enrage handle, my guess is you would have to replace the entire handle assembly.

Problem 3 sounds exactly like a blower motor resister. I've sold plenty of these working at O'Reilly Auto parts. The resister has different wires with different resistance to produce the different speeds. But one, usually the high, has no resistance so when the part goes bad the one speed still works.

As far as maintenance, I would say spark plugs. I just put in Autolite XP Iridiums and have had good luck with them in my 05 ST. I would say maybe a fuel filter. Other than that making sure tires stay inflated properly.

Good luck
Brian
__________________
2005 ZX4 ST, Stealth CAI (so far)
Used to have, and will always regret selling, 1970 Mach 1.
"Everday is a good day, just try missing one."
"As soon as we're born we start dying, so you might as well have a good time."
SilverST05 is offline  
    Reply With Quote
Old 09-30-2012, 09:22 AM   #5
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,064
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
^^ I second that.

Adding that you should carefully inspect the coil boots- the rubber part that connects to the spark plug. Mine were bad around that time. The boot simply pulls off the coil- although it's easier if fold the plug end back past the coil first to break it loose. Look for cracks or other signs of obvious rubber failure. Boots cost about $5-8 each, and come with the spring and magnet inside. If you see any oil on the boots, then you need a valve cover gasket. Always install spark plugs with a dab of silver anti-seize on the threads.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote
Old 09-30-2012, 12:42 PM   #6
bloostd
Focus Jr. Enthusiast
 
Join Date: Sep 2008
Fan#: 59310
Location: Washington, D.C., DC
What I Drive: 2005 Ford Focus ST Black

Posts: 38
FF Reputation: 1 bloostd Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by SilverST05 View Post
First problem sounds like the headlight switch needs replaced.

The E brake thing, I have no idea never tore apart an enrage handle, my guess is you would have to replace the entire handle assembly.

Problem 3 sounds exactly like a blower motor resister. I've sold plenty of these working at O'Reilly Auto parts. The resister has different wires with different resistance to produce the different speeds. But one, usually the high, has no resistance so when the part goes bad the one speed still works.

As far as maintenance, I would say spark plugs. I just put in Autolite XP Iridiums and have had good luck with them in my 05 ST. I would say maybe a fuel filter. Other than that making sure tires stay inflated properly.

Good luck
Brian
Thanks Brian,

Before I moved out to D.C. I changed the fuel filter at around 68k miles. Thing was completely pluggged. Sometimes I still get hard starts every now and then when I need to give it some gas. I've replaced the battery too.

Yes, time to look into some new times, this car sat salvaged for about 3 years. It was pretty nasty when I got it, but at the price. It was a steal, and it looks like a well taken care of 05' st. haha.
So you think the headlight switch is just the switch? not a ground? Errr. You're right. If it was a ground it wouldn't show me lights at all on cluster =D. Derp.

Quote:
Originally Posted by whynotthinkwhynot View Post
^^ I second that.

Adding that you should carefully inspect the coil boots- the rubber part that connects to the spark plug. Mine were bad around that time. The boot simply pulls off the coil- although it's easier if fold the plug end back past the coil first to break it loose. Look for cracks or other signs of obvious rubber failure. Boots cost about $5-8 each, and come with the spring and magnet inside. If you see any oil on the boots, then you need a valve cover gasket. Always install spark plugs with a dab of silver anti-seize on the threads.
Excellent!

Thanks for the tips. Motorcraft plugs and coils?

Next weekend I'll be doing all this stuff.

Where would you go for an Ebrake handle? and the HVAC switch/ headlight switch?

Thanks again

Bret
__________________
2005 Focus ST
2004 Screaming Yellow Cobra, 2.8 Kenne Bell...slow
2006 Focus ST SAP- Sold
2004 EAP SVT Focus- sold
2003 DSG Cobra 2.3 Whipple Vert - Sold
bloostd is offline  
    Reply With Quote
Old 09-30-2012, 12:43 PM   #7
SilverST05
Focus Enthusiast
 
SilverST05's Avatar
 
Join Date: Aug 2012
Fan#: 103209
Location: Urbandale, IA
What I Drive: 2005 Silver Frost ST

Posts: 189
FF Reputation: 1 SilverST05 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by whynotthinkwhynot View Post
^^ I second that.

Adding that you should carefully inspect the coil boots- the rubber part that connects to the spark plug. Mine were bad around that time. The boot simply pulls off the coil- although it's easier if fold the plug end back past the coil first to break it loose. Look for cracks or other signs of obvious rubber failure. Boots cost about $5-8 each, and come with the spring and magnet inside. If you see any oil on the boots, then you need a valve cover gasket. Always install spark plugs with a dab of silver anti-seize on the threads.
Good call on the boots. I forgot I did that when I did the plugs. Really easy and fairly cheap for a little extra protection.
__________________
2005 ZX4 ST, Stealth CAI (so far)
Used to have, and will always regret selling, 1970 Mach 1.
"Everday is a good day, just try missing one."
"As soon as we're born we start dying, so you might as well have a good time."
SilverST05 is offline  
    Reply With Quote
Old 09-30-2012, 12:48 PM   #8
SilverST05
Focus Enthusiast
 
SilverST05's Avatar
 
Join Date: Aug 2012
Fan#: 103209
Location: Urbandale, IA
What I Drive: 2005 Silver Frost ST

Posts: 189
FF Reputation: 1 SilverST05 Good Standing Member
Buy-Sell-Trade Rating: (0)
I would say Motorcraft or Autolite plugs. O'Reilly carries both. You probably just need boots, not coils. Coils can get expensive. I used the Borg Warner boots from O'Reilly but most will be about the same. Sorry I'm pimping O'Reillys cause that's where I work.
__________________
2005 ZX4 ST, Stealth CAI (so far)
Used to have, and will always regret selling, 1970 Mach 1.
"Everday is a good day, just try missing one."
"As soon as we're born we start dying, so you might as well have a good time."
SilverST05 is offline  
    Reply With Quote
Old 09-30-2012, 12:51 PM   #9
SilverST05
Focus Enthusiast
 
SilverST05's Avatar
 
Join Date: Aug 2012
Fan#: 103209
Location: Urbandale, IA
What I Drive: 2005 Silver Frost ST

Posts: 189
FF Reputation: 1 SilverST05 Good Standing Member
Buy-Sell-Trade Rating: (0)
The headlight switch and blower resister would be available at O'Reillys :) or any parts place. The ebrake handle I'm guessing you would have to search online or salvage yards. Not on the aftermarket. And I'm doubtin the dealers would still carry it unless they are still using the same design.
__________________
2005 ZX4 ST, Stealth CAI (so far)
Used to have, and will always regret selling, 1970 Mach 1.
"Everday is a good day, just try missing one."
"As soon as we're born we start dying, so you might as well have a good time."
SilverST05 is offline  
    Reply With Quote
Old 09-30-2012, 05:58 PM   #10
bloostd
Focus Jr. Enthusiast
 
Join Date: Sep 2008
Fan#: 59310
Location: Washington, D.C., DC
What I Drive: 2005 Ford Focus ST Black

Posts: 38
FF Reputation: 1 bloostd Good Standing Member
Buy-Sell-Trade Rating: (1)
What kind of fuel economy are you getting in your 2.3l?
im getting like 250-300miles tank?
is it worth it to get Toms Tune? I had it on my SVTF.
This is just my daily driver.

thanks guys
__________________
2005 Focus ST
2004 Screaming Yellow Cobra, 2.8 Kenne Bell...slow
2006 Focus ST SAP- Sold
2004 EAP SVT Focus- sold
2003 DSG Cobra 2.3 Whipple Vert - Sold
bloostd is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:22 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.