Electrical issue I think - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-16-2012, 02:43 PM   #1
Lecky
Focus Jr. Enthusiast
 
Join Date: Aug 2012
Fan#: 102721
Location: Manchester, United Kingdom
What I Drive: Ford Focus 1.8 Zetec, Blue, 1999

Posts: 32
FF Reputation: 1 Lecky Good Standing Member
Buy-Sell-Trade Rating: (0)
Electrical issue I think

Having trouble with my Electrics in need of abit of help.

First of all I've checked all the fuses in both boxes on my focus including the fuse behind the fuse box hidden behind the glove box.

My Stereo wont even turn on but I dont know if it a broken stereo as I have not long had the car or whether it is maybe a fault in the wiring somewhere on the car that could be causing it, also checked the fuses.

When I turn the car headlights on in the car I notice everything is lit up barring my drivers side window controls. although this is not a major issue im just wondering why its doing this as Im also having trouble with the central locking and Im not sure if its all connected.

The central locking I can unlock the doors with the fob and open my boot with the fob but cant lock the doors with fob I have to use the key.

Ive noticed when I start my car that the button next to rear window heater button. The internal air circulation one always switches on on startup Im not sure if this is normal? But when its wet sometimes it wont switch on and wont work at all.

A couple of times when the car is turning on full lock ive had the issue of the car just stopping with the engine still running and the steering really stiff as if there is no power steering.

I know there is a hell of a lot of information here my guess is I have a dodgy wire somewhere that maybe stripped a little or loose? Any help with any of this would be greatly appreciated. Anything I can do myself is alot better than the garage charging me to fix everything.

Cheers guys


Lecky is offline  
    Reply With Quote
 

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:25 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.