Focus 2012 Electrical Problems - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-22-2012, 09:12 PM   #1
NavinJohnson
Focus Rookie
 
Join Date: Mar 2012
Fan#: 96734
Location: Horseshoe Bay, TX
What I Drive: 2012 Silver Focus

Posts: 4
FF Reputation: 1 NavinJohnson Good Standing Member
Buy-Sell-Trade Rating: (0)
Focus 2012 Electrical Problems

Hello,
Just hit about 15k miles on my 2012 Focus and haven't had any problems until today.
In the drive-thru of McDonalds and my dash starts throwing odd messages. "Transmission not in park" and "Brake fluid low" (Brake Fluid is not low). The lights continue flashing and then go dim. My Speedometer and tach are acting like there is a short, going on and off. My A/C comes on and off (mostly off). Turn signals stopped working.
The only window that works is driver's side rear and it doesn't always work. Finally got my driver's side window rolled up. I just got out of my car and the "beep beep" like a door was open stayed on even after I turned my car off and closed the door. I could also hear the radio was still on. I came back after 5 minutes and both were still on so I disconnected my battery.
I will certainly take it to the dealer tomorrow but it's a long drive and it's hot in Texas. No A/C and can't roll the windows down.
Sounds like a major computer is malfunctioning. Anyone have any ideas??

Thanks much,


NavinJohnson is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-22-2012, 09:39 PM   #2
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,272
Points 27,546, Level 98
Points: 27,546, Level: 98 Points: 27,546, Level: 98 Points: 27,546, Level: 98
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 13%
Activity: 13% Activity: 13% Activity: 13%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
I've not seen this problem on this Forum yet- as if that's any consolation. Of course, you're going to take it to the dealer. If you have any problems with the dealer's service dept, then please send a private message through this forum to FordCustomerService. That's our Ford corporate representative, and she can help you with your dealer if you have problems. Her name is Noemi.

Good luck and I wish I could be more help.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is online now  
    Reply With Quote Quick reply to this message
Old 03-22-2012, 09:52 PM   #3
NavinJohnson
Focus Rookie
 
Join Date: Mar 2012
Fan#: 96734
Location: Horseshoe Bay, TX
What I Drive: 2012 Silver Focus

Posts: 4
FF Reputation: 1 NavinJohnson Good Standing Member
Buy-Sell-Trade Rating: (0)
I appreciate the reply, thanks. I just tried attaching the battery again and lights and dash display still stay on when the key is removed and door is closed. Going to have to leave it detached overnight.
I hope others do not have this problem but will post when I have resolve.
btw...haven't seen Fritz the Cat in a while :)
NavinJohnson is offline  
    Reply With Quote Quick reply to this message
Old 03-22-2012, 10:02 PM   #4
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,272
Points 27,546, Level 98
Points: 27,546, Level: 98 Points: 27,546, Level: 98 Points: 27,546, Level: 98
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 13%
Activity: 13% Activity: 13% Activity: 13%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
Fritz is on Netflix.

Quick story: On the 05 Focus there are 2 small ground wires that connect to the chassis and the wiring harness from the negative battery terminal. Just one of those lost it's connection from a broken ring terminal. When I turned the key on- the wipers came on, even though the switch was off, there were lights in the dash, and the radio came on full blast.

Your problem is probably something simple like that.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is online now  
    Reply With Quote Quick reply to this message
Old 03-23-2012, 09:31 AM   #5
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,548
Points 3,284, Level 35
Points: 3,284, Level: 35 Points: 3,284, Level: 35 Points: 3,284, Level: 35
Level Up 56% Completed
Level up: 56% Level up: 56% Level up: 56%
Forum Activity 18%
Activity: 18% Activity: 18% Activity: 18%
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by NavinJohnson View Post
Hello,
Just hit about 15k miles on my 2012 Focus and haven't had any problems until today...In the drive-thru of McDonalds and my dash starts throwing odd messages. "Transmission not in park" and "Brake fluid low" (Brake Fluid is not low)...Sounds like a major computer is malfunctioning. Anyone have any ideas??...
Hey NavinJohnson,

Here I be!

Send me a PM with the VIN, current mileage, personal and dealer contact info, and I'll escalate your concern to the Customer Service Manager.

Quote:
Originally Posted by whynotthinkwhynot View Post
I've not seen this problem on this Forum yet- as if that's any consolation...then please send a private message through this forum to FordCustomerService. That's our Ford corporate representative, and she can help you with your dealer if you have problems. Her name is Noemi...
Morning whynothinkwhynot,

Thanks for bringing the OP concern to my attention!

Have an AWESOME WEEKEND!

Noemi
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordServiceUS facebook.com/FordFocus

M - F 11 a.m. - 8 p.m. ET | Send a PM? Pls allow 2 business days for reply
FordService is offline  
    Reply With Quote Quick reply to this message
Old 03-23-2012, 02:23 PM   #6
NavinJohnson
Focus Rookie
 
Join Date: Mar 2012
Fan#: 96734
Location: Horseshoe Bay, TX
What I Drive: 2012 Silver Focus

Posts: 4
FF Reputation: 1 NavinJohnson Good Standing Member
Buy-Sell-Trade Rating: (0)
I just sent my info off to Noemi.
I haven't had a chance to take it in to the dealer yet but this morning, after my battery had been disconnected overnight, everything was working on my drive to work. A/C windows everything.
At lunch, after about 30 minutes of driving, it started to do the exact same thing. It just started to get warm in Texas and seems to happen after the car is running for a while.

I'll let you know what I find.
NavinJohnson is offline  
    Reply With Quote Quick reply to this message
Old 03-23-2012, 03:57 PM   #7
NavinJohnson
Focus Rookie
 
Join Date: Mar 2012
Fan#: 96734
Location: Horseshoe Bay, TX
What I Drive: 2012 Silver Focus

Posts: 4
FF Reputation: 1 NavinJohnson Good Standing Member
Buy-Sell-Trade Rating: (0)
Not a lot of help...

I just got a call back from the gentleman in the service department of the dealer and they don't have any loaner vehicles.
I told him I can bring it in tomorrow and I will have transportation. He said they have a "skeleton crew" on Saturday and no one who can work on it.
I said I can bring it in Monday and was told he would probably be in the same boat with loaner cars. Really? 89 degrees with black leather, no A/C, can't roll down the windows, and the weekend coming up and I can't get it looked at?
The next closest dealer is 1.5 hours away.
NavinJohnson is offline  
    Reply With Quote Quick reply to this message
Old 03-23-2012, 04:14 PM   #8
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,548
Points 3,284, Level 35
Points: 3,284, Level: 35 Points: 3,284, Level: 35 Points: 3,284, Level: 35
Level Up 56% Completed
Level up: 56% Level up: 56% Level up: 56%
Forum Activity 18%
Activity: 18% Activity: 18% Activity: 18%
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by NavinJohnson View Post
I just sent my info off to Noemi...
Hello NavinJohnson,

Got it! Check your inbox when you have a chance.

Have a GREAT weekend!

Noemi
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordServiceUS facebook.com/FordFocus

M - F 11 a.m. - 8 p.m. ET | Send a PM? Pls allow 2 business days for reply
FordService is offline  
    Reply With Quote Quick reply to this message
Old 09-12-2012, 02:46 PM   #9
mfandetti
Focus Rookie
 
Join Date: Sep 2012
Fan#: 103751
Location: Wrentham, MA
What I Drive: 2012, white, SE

Posts: 4
FF Reputation: 1 mfandetti Good Standing Member
Buy-Sell-Trade Rating: (0)
2012 Focus SE, 5200 miles. Electrical systems suddenly failed (all instruments, turn signals, lights, etc.), wipers went berserk, etc. without hint of warning. Suspect same issue as others report here. Dealer is replacing "body control module." Not optimistic based on what is posted here. Has anyone resolved these problems successfully?
mfandetti is offline  
    Reply With Quote Quick reply to this message
Old 09-13-2012, 08:49 AM   #10
suss6052
Focus Addict
 
suss6052's Avatar
 
Join Date: Feb 2012
Fan#: 95752
Location: ..., MI
What I Drive: 2013 Ford Focus ST2 Ingot Silver

Posts: 12,798
Points 9,871, Level 66
Points: 9,871, Level: 66 Points: 9,871, Level: 66 Points: 9,871, Level: 66
Level Up 56% Completed
Level up: 56% Level up: 56% Level up: 56%
Forum Activity 28%
Activity: 28% Activity: 28% Activity: 28%
FF Reputation: 24 suss6052 Great Standing Member
Buy-Sell-Trade Rating: (3)
Quote:
Originally Posted by B-lou View Post
Welcome to Ford motor company where problems seems to never get fixed and you have to arrange transportation for yourself cause no loaners available and by the way you will probably have to continue to go back numerous times before anything gets done if ever...B-lou
The issue with a loaner car is really up to the dealer unless you had the extended service contract with rental coverage at which point they have to provide you with a car and not just a shuttle ride to the office or home.

That has more to do with the dealers being cheap than being Ford Motor Company policy. Its cheaper for them to run a van or two as a shuttle than to write off a dealer demo for loaner purposes in many cases so they choose that route preferring to pawn off the rental coverage instead.

That's an issue to take up with the dealer.

As to the repair problem if the issue doesn't get fixed why would you take the car back to the same dealer who didn't fix it the first time?
suss6052 is online now  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:09 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat