Focus Sport SCT Chip Problem. Will they correct it? - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-16-2004, 09:53 PM   #1
derf0069
Focus Enthusiast
 
Join Date: Feb 2004
Fan#: 2974
Location: turlock,ca
What I Drive: 2000 red zx3

Posts: 265
FF Reputation: 1 derf0069 Good Standing Member
Buy-Sell-Trade Rating: (0)
Focus Sport SCT Chip Problem. Will they correct it?

I've had a sputter in my car durring acceleration and shifting at lower RPM's ever since i put in my Focus Sport SCT Chip. I thought that maybe the plugs and wires needed to be changed due to the advanced timing, so I did that. Was still there. Tried new factory plugs and wires and it's still there. Could the clutch be slipping? No that's not it either.

After a lot of searching, troubleshooting, and imput from all great focus enthusiasts I finally pulled the chip out and TA DA. Sputtering is now gone and feels like i have more power. I am going to email Focus Sport tonight and call them in the morning to see if they are going to compensate in any way. Hopefuly they will reprogram it at no charge. the only program I have on it is to disable the second O2 sensor.

I have heard that other people have had this problem with their Focus Sport SCT Chip. If anyone else has had this problem please let leave your feedback and let me and the others who are having this problem know how Focus Sport treated you. I just think that as much as we spend on the chip it should perform as expected. Thanks.


__________________
aem cold air intake, focus central 2 piece under drive pulleys, focus central race header and flex pipe, magnaflow catback, 15.81 1/4 mile with crappy tires and lots of wheel hop.
derf0069 is offline  
    Reply With Quote
 

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:34 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat