FSWerks Cool-Flo Intake Installation Problems - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > DURATEC Performance (2003-2011)

DURATEC Performance (2003-2011) The place to chat about any Duratec 23, 23E, and 20 engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-19-2011, 10:14 AM   #1
lacole725
Focus Enthusiast
 
lacole725's Avatar
 
Join Date: Apr 2011
Fan#: 85112
Location: Auburn, AL
What I Drive: 2010 Ingot Silver Focus SE

Posts: 348
FF Reputation: 1 lacole725 Good Standing Member
Buy-Sell-Trade Rating: (0)
FSWerks Cool-Flo Intake Installation Problems

I need some help. I attempted to install the FSWerks Cool-Flo Intake yesterday morning on my 2010 Sedan. Once I got everything taken off, I started the installation. The first problem I had was the MAF sensor housing was not big enough. It looked like is had some extra paint or slag in it, so I had to find something the file it out to make the hole bigger. Once I got that done, I attached the filter and tried sliding it into the car. In all the pictures I had seen, I never saw any lines below where the airbox sits. I think they are transmission cooler lines or something, but I managed to snake around them.

Now for the big problem. When I tried lining up the intake tube to the throttle body, is was extremely off center. I would have to bring the tube upwards and tilt it in an awkward position. To make it worse, the throttle body is smaller than the intake tube. The supplied silicone couplers are 3" in diameter, so it was too big for my 2.75" throttle body. I tried attaching the coupler to the throttle body as best I could then sliding the tube in and attaching that. I was trying to get it as tight as possible, then the hose clamp broke. After finding a thicker one somewhere, I resumed. The rubber mount that is screwed into the car for the intake to sit on is nowhere near the intake bracket. I had to pull the intake and mount towards each other then install the nut. I thought it looked ok and that it would work. The other problem I had was with the MAF sensor when trying to plug it in. It was extremely short, like more than anyone else had said. I finally got it to reach and plug in, but it looks stupid.

So after finally installing everything, I drove it down the road a couple times and everything seemed to be ok. The only thing I noticed was my car made a farting noise from the intake everytime I turned it off. When my girlfriend got home, we went to my cousin's cookout at his home about 45 minutes away. When I got there and pulled into the yard, I heard a whistling or sucking sound. I thought it sounded like air, so I checked it before I left. Turns out the coupler slipped off the throttle body and was sucking air in. I asked my cousin for a screwdriver and he held the tube over while I retightened the clamp. When I got done, we sat there and watched the tube slide right back off again because the mount was pulling it one direction and the coupler was too big to begin with. I made it to the auto store after cutting out at a red light one time and found a really thick hose clamp like the other one I had put on earlier. I tightened it up pretty good and I made it home without anymore problems.

Has anyone else had this kind of problem and how did you fix it? I think that if I find a 2.75" to 3" adapter hose it will fix that problem. Then if I drill a new hole for the mount to sit in, it will fix the alignment issue. Does that sound about right?

You can see how far away the mount is and how far stretched the MAF Sensor is.


Different angle of how far away the mount is from the bracket. I ended up unscrewing it some to give me a little more leverage.


How I ended up fixing the coupler. These clamps are considerably stronger than the flimsy ones FSWerks sent.



__________________
2010 Ford Focus SE|Ingot Silver Metallic|Debadged Deck Lid|FSWerks Cool-Flo Race Air Intake System|FSWerks SCT X3, 93 Octane|CFM Lower Engine Torque Mount w/ Race Bushings|Steeda Rear Swaybar|Pioneer 3-Way Speakers|Budget Race Exhaust
lacole725 is offline  
    Reply With Quote
 

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:10 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.