HELP flooding problem!! - Page 2 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus First Generation > ZETEC Performance (2000-2004)

ZETEC Performance (2000-2004) The place to chat about any 2.0L Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-24-2003, 12:31 AM   #11
MyFocusIsSlow
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 506
Location: Federal Way
Posts: 32
FF Reputation: 1 MyFocusIsSlow Good Standing Member
Buy-Sell-Trade Rating: (0)
I tried jumpstarting it and that didn't work. Right now it only makes a clicking sound everytime I turn the key, it won't even turn over. What could be wrong!!
MyFocusIsSlow is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2003, 10:16 AM   #12
Kicknzx3
AKA Toyotech
 
Kicknzx3's Avatar
 
Join Date: Jun 2003
Fan#: 9
Location: Oak Ridge, NJ
What I Drive: A few

Posts: 4,043
FF Reputation: 1 Kicknzx3 Good Standing Member
Buy-Sell-Trade Rating: (4)
seriously, it could be locked up...specially since its been 2 days, just be happy you didn't put a hole in your block. put the stock intake on and bring it to the dealer. tell them that you went through a big puddle the other night and it made the car surge heavily, you pulled over, let it sit and you drove home...two days later it won't start. was the check engine light flashing?
__________________
2012 Toyota Camry SE
2012 Chevy Cruze LT/RS
2006 Ford Escape XLE V6
1991 Ford Mustang LX/5.0
Kicknzx3 is offline  
    Reply With Quote
Old 10-24-2003, 10:37 AM   #13
focus
Focus Addict
 
focus's Avatar
 
Join Date: Sep 2003
Fan#: 276
Location: ATL
What I Drive: 4Dr Sony Edition

Posts: 798
FF Reputation: 1 focus Good Standing Member
Buy-Sell-Trade Rating: (0)
I wouldn't try cranking it until after you change the oil and remove the spark plugs
focus is offline  
    Reply With Quote
Old 10-24-2003, 11:54 AM   #14
Hank
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 756
Location: Hilltown
What I Drive: Foci

Posts: 41
FF Reputation: 1 Hank Good Standing Member
Buy-Sell-Trade Rating: (0)
Pull the plugs and change the oil, as so many others have said. I hydrolocked a 4X4 years ago and had the exact same symptom. Turn the key = click. Changed a starter and battery before I checked the oil on a fluke and it smelled like gas. ( float in carb had stuck open, gravity and siphoning effect caused the entire motor to be filled with gas, locking it up tight)
__________________
Just because I'm wrong doesn't mean your right.
Hank is offline  
    Reply With Quote
Old 10-24-2003, 03:41 PM   #15
MyFocusIsSlow
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 506
Location: Federal Way
Posts: 32
FF Reputation: 1 MyFocusIsSlow Good Standing Member
Buy-Sell-Trade Rating: (0)
could the starter be bad?
MyFocusIsSlow is offline  
    Reply With Quote
Old 10-26-2003, 09:59 PM   #16
2001focusse
Focus Rookie
 
Join Date: Oct 2003
Fan#: 1446
Location: maine
What I Drive: 2001 focus se 1963 merc comet

Posts: 12
FF Reputation: 1 2001focusse Good Standing Member
Buy-Sell-Trade Rating: (0)
pull the plugs and tap the key to see if the engine even turns but dont crank it if it does. if it turns, drain the oil. if it doesn't you killed the engine.
2001focusse is offline  
    Reply With Quote
Old 10-26-2003, 10:03 PM   #17
2001focusse
Focus Rookie
 
Join Date: Oct 2003
Fan#: 1446
Location: maine
What I Drive: 2001 focus se 1963 merc comet

Posts: 12
FF Reputation: 1 2001focusse Good Standing Member
Buy-Sell-Trade Rating: (0)
is your car stick or auto? if it is stick, pull the spark plugs, put the car in secong gear and push it 2 feet to see if the engine turns to rule out the starter.
2001focusse is offline  
    Reply With Quote
Old 10-30-2003, 01:28 AM   #18
MyFocusIsSlow
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 506
Location: Federal Way
Posts: 32
FF Reputation: 1 MyFocusIsSlow Good Standing Member
Buy-Sell-Trade Rating: (0)
Hey I just pulled out the spark plugs and the wires and turned on the engine and a lot of water squirted out. So far so good, as far as I thought. Then I installed new spark plugs and then tried to turn on the engine and it tried to turn over but then back to square one and just clicked. what else could be the problem? Could it be that their is moisture in the distribitor cap or what?
MyFocusIsSlow is offline  
    Reply With Quote
Old 10-30-2003, 11:14 AM   #19
Hank
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 756
Location: Hilltown
What I Drive: Foci

Posts: 41
FF Reputation: 1 Hank Good Standing Member
Buy-Sell-Trade Rating: (0)
Did you change the oil? Water may have ran down past the rings. Pull your dipstick and take a look, your oil level may be way high. FWIW that's how I finally discovered my motor was hydrolocked, after changing the starter and battery. After you've changed the oil&filter you can pretty much rule out hydrolock, and then it would seem your into something electrical ie; starter, or stater solenoid. Good luck!
__________________
Just because I'm wrong doesn't mean your right.
Hank is offline  
    Reply With Quote
Old 10-30-2003, 11:16 PM   #20
MyFocusIsSlow
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 506
Location: Federal Way
Posts: 32
FF Reputation: 1 MyFocusIsSlow Good Standing Member
Buy-Sell-Trade Rating: (0)
Come on guys and girls, I don't want to pay a towing company money to drive it to a repair business to tell me its just a simple thing. There has to be something else wrong.
MyFocusIsSlow is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
focus ignition problem j.a.dj General Technical Chat 6 12-12-2007 05:52 PM
2002 zx3 electrical problem taco502001 General Technical Chat 5 04-21-2004 02:04 PM
Fuel Problem in '03 ZX3 IHateRice General Technical Chat 18 04-15-2004 09:39 AM
problem????????? MichaelMcMahan SVT Performance (2002-2004) 17 04-03-2004 08:08 PM
Sparco Pedal problem Seashrimp MK1 Interior Mods & Upgrades 9 03-31-2004 09:37 AM


All times are GMT -5. The time now is 05:01 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.