MyFord Touch update problem - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-23-2013, 05:48 PM   #1
Silver12Hatch
Focus Rookie
 
Join Date: Sep 2011
Fan#: 90336
Location: Orlando, FL
What I Drive: 2012 Silver Focus Hatchback SEL

Posts: 9
FF Reputation: 1 Silver12Hatch Good Standing Member
Buy-Sell-Trade Rating: (0)
MyFord Touch update problem

I just tried to update my myford touch system with my usb drive. It said I was supposed to leave the car on for 60 minutes but after I started I realized I did not have that much time so I have to shut off the car after like 15 minutes. After a couple more times of not leaving the car on for 60 minutes (it wouldn't let me exit the update), I finally sat there for more than an hour and it did not finish the update. The last half hour the screen was just black. Now when I turn the car on the screen is just black. Every 5 or 10 minutes it does a system maintenance thing and the radio turns on but I only see the maintenance screen for like a minute then it shuts off again. What do I do? I really don't want to bring it into ford cuz thats going to take forever. Anyway to reset the system?


Silver12Hatch is offline  
    Reply With Quote
Old 03-23-2013, 05:57 PM   #2
1slofofo
Adam
 
1slofofo's Avatar
 
Join Date: Dec 2011
Fan#: 92422
Location: Chicago, IL
What I Drive: Mk3

Posts: 2,095
FF Reputation: 6 1slofofo Good Standing Member
Buy-Sell-Trade Rating: (1)
Consider making an appointment, I made one for the TSB and they took me right as I got there.
__________________
Simplicity is the ultimate sophistication.
1slofofo is offline  
    Reply With Quote
Old 03-23-2013, 08:30 PM   #3
feta_mgp
Focus Fanatic
 
feta_mgp's Avatar
 
Join Date: Jul 2011
Fan#: 88210
Location: Vero Beach, FL
What I Drive: 2012 SGM Focus SEL

Posts: 2,637
FF Reputation: 7 feta_mgp Good Standing Member
Buy-Sell-Trade Rating: (0)
Neverrrrr kill power during an update!!!

But, Ford should be able to wipe it and re-flash it with the updated version.
__________________
2012 SGM SEL Sedan Job 1 BD 6/2011
FSWERKS Cool-Flo w/ ITG Filter | FSWERKS Stealth Exhaust | 17x7.5 Axis Sport XMX Graphite wheels | Eibach Sportlines on Ti Handling Pkg bits
Sonic Crew #28
feta_mgp is offline  
    Reply With Quote
Old 03-23-2013, 10:24 PM   #4
Text12
Focus Rookie
 
Join Date: Apr 2012
Fan#: 98327
Location: visalia, CA
What I Drive: 2012 White Titanium

Posts: 2
FF Reputation: 1 Text12 Good Standing Member
Buy-Sell-Trade Rating: (0)
Bad news, you might be screwed. Something simmilar happed to me durring the update. I didn't kill the power but i got an error about 45 min into the installation and it screwed the radio. It's been broken for a month and my dealer is still working on it. After 5 trips into the dealer they finally got ford to condem the part but new units are on back order (with no eta) so they finally pulled the unit and sent it in to a specialist.

Your dealer is going to have to look at it. Hopefully your case is better than mine.
Text12 is offline  
    Reply With Quote
Old 03-24-2013, 05:22 AM   #5
lewisra
Focus Addict
 
Join Date: Dec 2011
Fan#: 93289
Location: Howell, MI
What I Drive: 2012 Tuxedo Black SEL

Posts: 570
FF Reputation: 3 lewisra Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Silver12Hatch View Post
I just tried to update my myford touch system with my usb drive. It said I was supposed to leave the car on for 60 minutes but after I started I realized I did not have that much time so I have to shut off the car after like 15 minutes. After a couple more times of not leaving the car on for 60 minutes (it wouldn't let me exit the update), I finally sat there for more than an hour and it did not finish the update. The last half hour the screen was just black. Now when I turn the car on the screen is just black. Every 5 or 10 minutes it does a system maintenance thing and the radio turns on but I only see the maintenance screen for like a minute then it shuts off again. What do I do? I really don't want to bring it into ford cuz thats going to take forever. Anyway to reset the system?
Might try pulling the fuses(search this site) or disconnecting the battery. I'd put the update in the USB before reconnecting.
lewisra is offline  
    Reply With Quote
Old 03-24-2013, 12:34 PM   #6
pozi240
Focus Enthusiast
 
Join Date: Feb 2012
Fan#: 94835
Location: Halifax, NS, Canada
What I Drive: 2012 Focus 5 door SEL Kona Blue

Posts: 360
FF Reputation: 4 pozi240 Good Standing Member
Buy-Sell-Trade Rating: (0)
You're not "screwed ", but you'll have to take it to the dealer and they will have to reset it with IDS and then reflash it again. No biggie.
__________________
2012 Focus SEL 5 door 303a w/Lux pkg in KonaBlue
2012 Escape Limited w/park assist
2010 F150 Supercrew XTR 5.4 4x4
2008 Kawasaki Concours 14 (street)
2008 Kawasaki ZX10R (track only)
pozi240 is offline  
    Reply With Quote
Old 05-30-2013, 12:20 AM   #7
Sinsneerly
Focus Rookie
 
Join Date: May 2013
Fan#: 115218
Location: Saskatoon, Canada
What I Drive: 2012 Dark Blue Focus Titanium

Posts: 1
FF Reputation: 1 Sinsneerly Good Standing Member
Buy-Sell-Trade Rating: (0)
Similar thing just happened to me on the weekend , I went through the process of downloading updates on to a usb , put the usb in my car and the update started ie. the 60 minute message etc. while I was sitting there with car running the screen message said restarting system , screen went black approx. 3 hours later and car running the whole time screen did not come back on and hasn't changed over the last few days. No radio , no sync , I tried pulling and reseating the fuses and pulling the battery cable with no luck.
Sinsneerly is offline  
    Reply With Quote
Old 05-31-2013, 09:14 AM   #8
JPopNC
Focus Enthusiast
 
JPopNC's Avatar
 
Join Date: Jul 2011
Fan#: 88327
Location: Lewisville, NC
What I Drive: 2012 Ingot Silver Titanium H-back

Posts: 399
FF Reputation: 1 JPopNC Good Standing Member
Buy-Sell-Trade Rating: (0)
Always take it to the dealer. No hassle and they usually will give you a loaner to drive. What could be easier than that?
__________________
2012 Silver Ingot Titanium Hatchback
Premium Package, Sport Handling Package 18" wheels
MFT w/Navigation, Parking Assist, Rain-sensing wipers, leather seats
JPopNC is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:05 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.