Rough idle, stalling and wrench light!! - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 01-11-2013, 11:30 AM   #1
VC25A2008
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108375
Location: ARVADA, CO
What I Drive: 2008, BLUE, FORD, FOCUS SES

Posts: 3
FF Reputation: 1 VC25A2008 Good Standing Member
Buy-Sell-Trade Rating: (0)
Angry Rough idle, stalling and wrench light!!


Hello,

Hoping the combined knowledge on this site can help. Recently purchased a 2008 SES sedan for my wife, she has to drive a lot for her job and needed a good car with better gas mileage.
Bought the car in November, and worked fine for about two weeks, no problems. Then one day without warning the car seemed to loose power and the wrench light came on. Read the manual and did some online research and found this to be a throttle or transmission problem. Yesterday while she was driving it the car went in to what i think is called "Limp Mode" and would only travel at 5 mph, she pulled over turned the car off, restarted it an the problem went away. Until this morning when I took it to work and it stalled, would idle rough then die. Restarted it only to have it idle so bad the car was shaking had to keep my foot on the brake to keep it from hitting the house.
Took the car to the local dealer to have it scanned (after it happend the first time) and was told it was the throttle body. Was an easy enough fix so purchased a new Throttle Body and installed it myself. Still had the same problem.
Took off the MAF sensor and cleaned it, nothing! Problem still persists! Am going to try the fuel filter and plugs this weekend.
Was also seeing this could be a problem with the Idle Air Control Valve. Does anyone know where this is located and how hard it is to clean/change? Any other helpful hints would be most appreciated is frustrating have already put more into repairs on this car then paid in payments. Seems to be a common problem and not getting any help from the local deal or Ford themselves.
Just more than a little frustrated at Ford, don't trust this car with my wife and kids and have had it less than two months.


VC25A2008 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:10 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.