Oil light on , 04 2.3 sedan. - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-04-2012, 09:00 PM   #1
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,466
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
Oil light on , 04 2.3 sedan.

just did an engine swap on my 04 zx4. went 2.3 to 2.3 and everything went fine , engine ran smooth , took it for a ride shut it off and when i turned it back on the light was on. Ive read it could be low pressure or a clog or the main bearings going , i really hope not since i just swapped this engine in.

ive got a spare 2.3 so i have good spare parts to use incase something is broken. My battery is also very very dead , wont hold a charge and my lights flicker , could this have something to do with it ?

Thanks in advance.


__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote
Old 12-04-2012, 09:31 PM   #2
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,272
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
Low voltage causes all sorts of weird things.
Sort the battery situation out first and go from there.
__________________
Don't "think outside the box".
There is no box.
Do it correct, or do it twice.
iminhell is offline  
    Reply With Quote
Old 12-04-2012, 09:33 PM   #3
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,466
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
Quote:
Originally Posted by iminhell View Post
Low voltage causes all sorts of weird things.
Sort the battery situation out first and go from there.
thanks , im gunna get a new battery for it tommorro. If it is still on , is there a way i can test for oil pressure with the onboard diagnoser ?

also , the engine has unkown mileage and has been sitting for over a year with crappy oil in it , i used 10-30 oil i had laying around and a new motor craft filter.
__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote
Old 12-05-2012, 11:45 AM   #4
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,466
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
Ok I put a new battery in and the light came on and flickered and went out. The odo says test on startup so I let the engine warm up the filter got warm and when I pulled the filler out of the valve cover and revved the engine and oil spit out and it looks like its getting oil. There is no weird noises or anything. I'm thinking its the sender I'm gunna pull the one off the engine I just pulled out and try it. Any more advice would be greatly apreciate it
__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote
Old 12-05-2012, 09:21 PM   #5
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,466
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
i dodged a bullet , replaced the oil pressure sender and all is good , drove the car about 10 miles with no issues. no weird nose , no loss of power. all seems good.
__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote
Old 12-06-2012, 04:48 AM   #6
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,065
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
is the odometer still in test mode?
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote
Old 12-06-2012, 05:10 AM   #7
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,466
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
nope , i wonder why it was.
__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:40 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.