Another IMRC "stuck" thread. - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-19-2012, 09:21 AM   #1
mwalsh
Focus Enthusiast
 
mwalsh's Avatar
 
Join Date: Jun 2008
Fan#: 56630
Location: Los Angeles, CA
What I Drive: 2003 Focus ZTS | 2005 Focus ZX3

Posts: 291
FF Reputation: 2 mwalsh Good Standing Member
Buy-Sell-Trade Rating: (2)
Another IMRC "stuck" thread.

I know there are some IMRC stuck threads already, and I thought about popping an old one to the top. But it seems like (on other boards, at least) you get as much abuse for reviving an old thread as you can for starting a new one on a subject that's already been covered some. So I went with a new one instead.

My wife's Focus popped a CEL a few days ago with code P2004 thrown, so I knew it would be manifold related - either tumble flaps or (being as this is a D23 IM) the runner control system. Starting the car, I observed correct operation of the tumble flap control valve, and it seemed like there was good vacuum. So no worries there.

Turning my attention to the runner control system, I first pulled the short vacuum line from the intake side of it's solenoid. There was a loud clunk from down deep inside the manifold and I'm like, "Hmm...I guess that must have been runner moving." I checked the vacuum lines and they all seemed OK. So, since I had a spare pair of solenoids, and they are the easiest parts of the system to get to, I changed the one out for the runner control system and we'll see if it solved the problem. I also have a spare actuator, and will change that out if we run the car up and the CEL comes back. Unfortunately, I wasn't able to get the car out into the neighborhood yesterday, and I don't think driving around our small block got the speed/revs up sufficiently for the runner to move.

I guess I'm confused about the physical form of the runner itself. It's clear there it's something inside the manifold that the actuator moves. But what? And is it likely to be sticking, or is it the collective experience here that it's far more likely to be either the solenoid or the actuator? If it does turn out to be the runner sticking, I'm guessing the IM has to come off? Can it then be cleaned (I'm guessing it would be carbon making it stick) or do I have to chuck the manifold away and get a new one?


mwalsh is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2012, 10:56 PM   #2
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,936
Points 2,052, Level 27
Points: 2,052, Level: 27 Points: 2,052, Level: 27 Points: 2,052, Level: 27
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 6%
Activity: 6% Activity: 6% Activity: 6%
FF Reputation: 88 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
The tumble flaps have the appearance of throttle butterfly valves and the bearings supporting the throttle spindle may wear. Therefore, It may be the flaps themselves making the noise as they shift position on the "throttle spindle" and contact the sides of the intake ports.
Don't confuse the tumble flaps with the variable length intake mechanism fitted to the SVT.
Some detail here for you with pics if you follow all the embedded links:
http://www.focusfanatics.com/forum/showthread.php?t=294508
BC_ZX3 is offline  
    Reply With Quote Quick reply to this message
Old 10-20-2012, 08:57 AM   #3
mwalsh
Focus Enthusiast
 
mwalsh's Avatar
 
Join Date: Jun 2008
Fan#: 56630
Location: Los Angeles, CA
What I Drive: 2003 Focus ZTS | 2005 Focus ZX3

Posts: 291
FF Reputation: 2 mwalsh Good Standing Member
Buy-Sell-Trade Rating: (2)
You're right...I had confused the tumble flaps with the IMRC. Silly me. So where I'm at now is that I have verified operation of both soleniods; and verified the arms on both the TF and IMRC actuators freely move when vacuum is applied. So I'm actually down to electrical checks on the IMRC as of today.

OK, so I've been out playing this morning. When I rev the car up by hand, I can see the the IMRC actuator is extending when the throttle is opened to (I guess) around 3000-3500rpm. So that would seem to be working properly.

The only change since goofing with the solenoids yesterday is that the Tumble Flap solenoid...when I disconnected the short vacuum line between it and the manifold yesterday, there was no change in engine tone, like there was when I did the same thing to the IMRC soleniod. Today engine tone changes when I disconnect either soleniod at the same place.

CEL hasn't come back again as of yet.

Last edited by mwalsh; 10-20-2012 at 01:09 PM.
mwalsh is offline  
    Reply With Quote Quick reply to this message
Old 10-29-2012, 02:30 PM   #4
mwalsh
Focus Enthusiast
 
mwalsh's Avatar
 
Join Date: Jun 2008
Fan#: 56630
Location: Los Angeles, CA
What I Drive: 2003 Focus ZTS | 2005 Focus ZX3

Posts: 291
FF Reputation: 2 mwalsh Good Standing Member
Buy-Sell-Trade Rating: (2)
CEL came back on after about a week, so I decided to take the plunge and change out the IMRC actuator, since I had a spare one of those too.

Once I got it changed out, I could tell immediately that the arm on the old part was retracting very slowly compared to the new one, once vacuum was applied. So while it was in a sense still working, it wasn't working effectively. And I guess not knowing how that part was supposed to look while it was operational had me tricked into thinking all was OK with it.

So I think all should be OK now, and I don't expect to see the CEL again now for a good long while. At least not for this issue.
mwalsh is offline  
    Reply With Quote Quick reply to this message
Old 10-29-2012, 02:47 PM   #5
2002FastFocusSVT
Focus Rookie
 
Join Date: Jun 2012
Fan#: 100770
Location: Toledo, OH
What I Drive: 2002 black focus svt

Posts: 2
FF Reputation: 1 2002FastFocusSVT Good Standing Member
Buy-Sell-Trade Rating: (0)
IMRC stuck open

My 2002 FSVT won't start. It throws a p1518 code and says the IMRC is stuck open. Could this be keeping the car from starting?
2002FastFocusSVT is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:15 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.