Low Level Brake Fluid - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-20-2012, 09:12 AM   #1
chum567
Focus Enthusiast
 
Join Date: Jun 2011
Fan#: 86507
Location: Montgomery, AL
What I Drive: 2012 Sterling Gray Focus SEL

Posts: 192
FF Reputation: 1 chum567 Good Standing Member
Buy-Sell-Trade Rating: (0)
Low Level Brake Fluid

My low level brake fluid light is coming on and off this morning on my way to work. Car has about 12,000 miles on it does that sound strange?


chum567 is offline  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 09:15 AM   #2
BetaDnB
Drum n Bass Lover
 
BetaDnB's Avatar
 
Join Date: Jul 2011
Fan#: 87466
Location: Buffalo, NY
What I Drive: 2012 Silver SE Sport

Posts: 2,044
Points 2,299, Level 28
Points: 2,299, Level: 28 Points: 2,299, Level: 28 Points: 2,299, Level: 28
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 13 BetaDnB Great Standing Member
Buy-Sell-Trade Rating: (0)
Have you actually stopped to check your fluid level or are you just continuing to drive with a low brake fluid warning while posting threads on FF? More so, has your brake pedal feel turned spongy?
__________________
Sedan Revolution #249 - 2012 SE Sport - ╠╬╝ - Ingot Silver - 201A - K&N w/ snorkel delete - Blox Type R Knob
BetaDnB is offline  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 09:22 AM   #3
chum567
Focus Enthusiast
 
Join Date: Jun 2011
Fan#: 86507
Location: Montgomery, AL
What I Drive: 2012 Sterling Gray Focus SEL

Posts: 192
FF Reputation: 1 chum567 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by BetaDnB View Post
Have you actually stopped to check your fluid level or are you just continuing to drive with a low brake fluid warning while posting threads on FF? More so, has your brake pedal feel turned spongy?
Man such a smart ass so early in the morning.....this just happened this morning for the first time and every time I came to a stop it came on then went away as soon as I started going again. I have not checked because I went straight into work and haven't had time and the brake pedal feels fine.
chum567 is offline  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 09:29 AM   #4
dan50
Focus Addict
 
Join Date: Nov 2011
Fan#: 91789
Location: Too much info, IL
What I Drive: 2012 SEL White Platinum 5 Dr 302A

Posts: 1,216
Points 3,034, Level 33
Points: 3,034, Level: 33 Points: 3,034, Level: 33 Points: 3,034, Level: 33
Level Up 90% Completed
Level up: 90% Level up: 90% Level up: 90%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 12 dan50 Great Standing Member
Buy-Sell-Trade Rating: (0)
It is strange. It could be just a bad sensor or truly low fluid. Take a look under the hood: if the level is OK it's probably a sensor issue that can be dealt with when you have time. If the fluid is actually low it means a trip to the dealer ASAP.

The fluid in reservoir is also used for the clutch, so be alert for odd behavior on that front, too. The cap on my reservoir was slightly loose when I took delivery, so that'd be another thing to check, even if the level is OK.
dan50 is online now  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 09:47 AM   #5
suss6052
Focus Addict
 
suss6052's Avatar
 
Join Date: Feb 2012
Fan#: 95752
Location: ..., MI
What I Drive: 2013 Ford Focus ST2 Ingot Silver

Posts: 12,923
Points 10,049, Level 66
Points: 10,049, Level: 66 Points: 10,049, Level: 66 Points: 10,049, Level: 66
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 24%
Activity: 24% Activity: 24% Activity: 24%
FF Reputation: 24 suss6052 Great Standing Member
Buy-Sell-Trade Rating: (3)
Quote:
Originally Posted by dan50 View Post
It is strange. It could be just a bad sensor or truly low fluid. Take a look under the hood: if the level is OK it's probably a sensor issue that can be dealt with when you have time. If the fluid is actually low it means a trip to the dealer ASAP.

The fluid in reservoir is also used for the clutch, so be alert for odd behavior on that front, too. The cap on my reservoir was slightly loose when I took delivery, so that'd be another thing to check, even if the level is OK.
The fluid on the DCT equipped cars is only used for the brakes. You have an SEL, the same as the OP, and considering that they are in AL. chances of them having a canadian spec manual is slim to none in the SEL. But otherwise this makes sense.
suss6052 is online now  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 09:31 AM   #6
BetaDnB
Drum n Bass Lover
 
BetaDnB's Avatar
 
Join Date: Jul 2011
Fan#: 87466
Location: Buffalo, NY
What I Drive: 2012 Silver SE Sport

Posts: 2,044
Points 2,299, Level 28
Points: 2,299, Level: 28 Points: 2,299, Level: 28 Points: 2,299, Level: 28
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 13 BetaDnB Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by chum567 View Post
Man such a smart ass so early in the morning.....
Sorry. You kind of left yourself wide open for it. Check the fluid level when you get a chance before you go anywhere. You only have to open the hood and look. Also check for leaks on the ground. It could be an actual problem or just a faulty sensor.

edit: I guess dan beat me to it.
__________________
Sedan Revolution #249 - 2012 SE Sport - ╠╬╝ - Ingot Silver - 201A - K&N w/ snorkel delete - Blox Type R Knob
BetaDnB is offline  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 09:48 AM   #7
jdetzel
Focus Enthusiast
 
Join Date: Aug 2012
Fan#: 102548
Location: Austin, TX
What I Drive: 2012 White Titanium Hatchback

Posts: 285
Points 173, Level 3
Points: 173, Level: 3 Points: 173, Level: 3 Points: 173, Level: 3
Level Up 46% Completed
Level up: 46% Level up: 46% Level up: 46%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jdetzel Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by chum567 View Post
My low level brake fluid light is coming on and off this morning on my way to work. Car has about 12,000 miles on it does that sound strange?
In addition to what Dan and Beta said, DONT drive it!
You are still under warranty. Call the dealer, tell them it is unsafe to drive and make them tow it.
jdetzel is offline  
    Reply With Quote Quick reply to this message
Old 09-20-2012, 10:37 AM   #8
oritpro
Focus Enthusiast
 
oritpro's Avatar
 
Join Date: Mar 2012
Fan#: 96148
Location: Portland, OR
What I Drive: 2012 Subaru Impreza Sport Limited

Posts: 441
Points 749, Level 14
Points: 749, Level: 14 Points: 749, Level: 14 Points: 749, Level: 14
Level Up 49% Completed
Level up: 49% Level up: 49% Level up: 49%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 2 oritpro Good Standing Member
Buy-Sell-Trade Rating: (0)
I get a low brake fluid warning when my car is parked facing down a slight (20-25 degree) incline, usually when backed into my driveway. It happened this morning again before I left for work.

I've checked the fluid level and it's fine but I am going to have the shop take a look at it anyway.
oritpro is offline  
    Reply With Quote Quick reply to this message
Old 11-01-2012, 11:10 PM   #9
2focuses
Focus Rookie
 
Join Date: Nov 2012
Fan#: 105549
Location: Paso Robles, CA
What I Drive: 2012 Gun Metal Gray Ford Focus

Posts: 2
FF Reputation: 1 2focuses Good Standing Member
Buy-Sell-Trade Rating: (0)
Whatever happened with your brake fluid level problem? Mine has been coming on in my 2012. I took it right away to the dealer and they checked the levels and said it was fine and it was a sensor but they needed it to come on and stay on to know where to fix it. This sounds odd that I just googled this problem and they don't know about it!
Thanks for any updates!
2focuses is offline  
    Reply With Quote Quick reply to this message
Old 11-02-2012, 10:39 AM   #10
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,687
Points 3,379, Level 36
Points: 3,379, Level: 36 Points: 3,379, Level: 36 Points: 3,379, Level: 36
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 22%
Activity: 22% Activity: 22% Activity: 22%
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by SportyChick View Post
This happened to me this morning on my way into work as well. Started the car and the warning came on and was gone when I started to drive. It came on a couple times more during my one hour commute but only momentarily. I just had a brake service done at the Ford dealership less then a week ago, last wednesday...
Quote:
Originally Posted by 2focuses View Post
This has been happening to my 2012. We took it right in... Ford Mechanics said that light has to stay on before they can find the bad sensor. By the way before everyone gets smart about it... they checked the levels first... saying it was a sensor. It is driving me crazy... comes on randomly all the time now but won't stay on. I have only had it for 6 months. I have a warranty but geesh this is annoying. I want a loaner car and for them to fix it NOW not while "I" the customer am waiting for it to come on...
Hi SportyChick and 2focuses,

I'd like to help by getting your cases escalated. To do this, I'll just need a bit of information from you. Please send me a PM with your VIN, dealer, mileage, daytime phone number, and full name; I'll make sure your regional customer service managers get looped in and address your concerns.

Have a great weekend!
Crystal
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordServiceUS facebook.com/FordFocus

M - F 11 a.m. - 8 p.m. ET | Send a PM? Pls allow 2 business days for reply
FordService is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:58 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat