need help figuring why rear license plate amp wont work...BLOWING FUSES - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-19-2012, 05:35 PM   #1
beeyellow
Focus Rookie
 
Join Date: Sep 2012
Fan#: 104004
Location: Goshen, OH
What I Drive: 2002 yellow focus zx3

Posts: 6
FF Reputation: 1 beeyellow Good Standing Member
Buy-Sell-Trade Rating: (0)
need help figuring why rear license plate amp wont work...BLOWING FUSES

Everytime i put a new fuse in it just blows. Almost like it may be grounded out somewhere..i need help fixing this problem.


beeyellow is offline  
    Reply With Quote
Old 09-19-2012, 05:40 PM   #2
ah1f39
Alone in the Cave
 
ah1f39's Avatar
 
Join Date: Oct 2009
Fan#: 70006
Location: In the Cave, MI
What I Drive: 2000 Explorer 4x4

Posts: 5,546
FF Reputation: 28 ah1f39 Great Standing Member
Buy-Sell-Trade Rating: (5)
Check the hatch wires where the enter the body.
ah1f39 is online now  
    Reply With Quote
Old 09-19-2012, 09:31 PM   #3
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,851
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Also the license plate bulb holder itself can retain water and short/corrode.
BC_ZX3 is offline  
    Reply With Quote
Old 09-19-2012, 10:53 PM   #4
my_beautious_ZX3
Focus Addict
 
Join Date: Feb 2006
Fan#: 32386
Location: Chicago, IL
What I Drive: 2002 charcoal XZ3

Posts: 745
FF Reputation: 5 my_beautious_ZX3 Good Standing Member
Buy-Sell-Trade Rating: (0)
When you pry out the clear plastic lens, you'll likely find that the bulb's metal spring contacts are completely corroded away, leaving nothing but a bare wire hanging loose. Hence, your short circuit.
__________________
"I'm jealous of girls because they get to wear dresses." (Todd Flanders)
my_beautious_ZX3 is offline  
    Reply With Quote
Old 12-02-2012, 07:56 PM   #5
beeyellow
Focus Rookie
 
Join Date: Sep 2012
Fan#: 104004
Location: Goshen, OH
What I Drive: 2002 yellow focus zx3

Posts: 6
FF Reputation: 1 beeyellow Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks for the ideas to try and fix it
beeyellow is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:17 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.