Brand new A/C short cycling already... - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus First Generation > MK1 Focus

MK1 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the first generation 2000-2007 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-09-2012, 07:26 PM   #1
n00btard
Focus Enthusiast
 
Join Date: Jul 2012
Fan#: 101317
Location: DFW, TX
What I Drive: 2013 VW Golf 2.5 3 door

Posts: 129
FF Reputation: 1 n00btard Good Standing Member
Buy-Sell-Trade Rating: (0)
Brand new A/C short cycling already...

So.....

I've just put in a new A/C system and it's short cycling two months later --WTF? On top of that when the clutch kicks on it tugs on the belt so hard that I can feel the loss of power to the wheels --I mean a noticable jerk. When I'm idling @1000RPMs (custom tune setting) the A/C clutch engaging pulls my engine down to 800RPMs and it's noticably taxing the engine.

I did this A/C system at the same time as my timing belt, serpintine belt, alternator upgrade, water pump and some other routine maitenence. The system is holding vacuum and it's still cold.......what the heck is STILL wrong?


n00btard is offline  
    Reply With Quote
Old 09-09-2012, 10:29 PM   #2
elsolo
Focus Fanatic
 
elsolo's Avatar
 
Join Date: Mar 2012
Fan#: 96835
Location: Long Beach, CA
What I Drive: 2003 dark shadow grey metallic ZX3

Posts: 2,169
FF Reputation: 17 elsolo Great Standing Member
Buy-Sell-Trade Rating: (1)
If it were slightly overcharged, it would have symptoms similar to what you describe.
-frequently cycling off due to overpressure switch
-increased load on compressor
-still cools OK
elsolo is offline  
    Reply With Quote
Old 09-09-2012, 11:44 PM   #3
n00btard
Focus Enthusiast
 
Join Date: Jul 2012
Fan#: 101317
Location: DFW, TX
What I Drive: 2013 VW Golf 2.5 3 door

Posts: 129
FF Reputation: 1 n00btard Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by elsolo View Post
If it were slightly overcharged, it would have symptoms similar to what you describe.
-frequently cycling off due to overpressure switch
-increased load on compressor
-still cools OK
I only have a low pressure side gauge. Do I need to get another to check if that's what's happening?

The other thing is that I can FEEL the the loss of power when clutch for the compressor engages --even in 5th gear. I thought that wasn't supposed to happen anymore (all my cars have been classics before now)
n00btard is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:09 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.