Just had timing belt and water pump changed now car is overheating?!?!? - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-10-2008, 01:46 PM   #1
DanielW
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 58023
Location: concord, nc
What I Drive: 2001 silver zx3

Posts: 59
FF Reputation: 1 DanielW Good Standing Member
Buy-Sell-Trade Rating: (0)
Just had timing belt and water pump changed now car is overheating?!?!?

ok so I just had some maintenance done on my car like 50 miles ago. I had the water pump, timing belt, tensioner, fuel pump, and brakes all changed. When I left the mechanics shop I noticed the car was running much better but there was a slight whine coming from the engine that would increase in pitch the faster I went. eventually it seemed to go away and the car was running great until about an hour ago. I pulled into school and right as i pulled into the parking deck i smelled the smell of a car overheating. I looked around to see who it was but as i continued through the deck the smell followed. I the pulled into a parking spot and saw the dreaded steam rising from the hood of the car. So its deffinitely overheating. What could be the problem? I bought the water pump from partstrain.com and when it came it said it was remanufactured. could it be bad? or is there something the mechanic could've screwed up? Please help!!! this is my daily driver and i need her running


DanielW is offline  
    Reply With Quote Quick reply to this message
Old 11-10-2008, 02:42 PM   #2
the Duff
Focus Enthusiast
 
the Duff's Avatar
 
Join Date: Nov 2008
Fan#: 60423
Location: East Moline, Illinois
What I Drive: 2009 Silver SES Coupe

Posts: 65
FF Reputation: 3 the Duff Good Standing Member
Buy-Sell-Trade Rating: (0)
Take it back to the mechanic. That should be a no brainer. The sad part is it sounds like you supplied your own parts, so if your water pump was bad out of the box you'll probably have to pay for the labor for them to replace it. I'm a mechanic at a Ford dealer and we warranty parts and labor for 12 months 12,000 miles, unless that is, the customer supplied there own parts. Likely not your water pump though. I bet someone forgot to tighten a clamp. Whining noise could possibly be overtightened timing belt. Couldn't tell you without looking at it though.
the Duff is offline  
    Reply With Quote Quick reply to this message
Old 11-10-2008, 02:57 PM   #3
DanielW
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 58023
Location: concord, nc
What I Drive: 2001 silver zx3

Posts: 59
FF Reputation: 1 DanielW Good Standing Member
Buy-Sell-Trade Rating: (0)
yeah I'm already taking it back to the mechanic. when you say clamp... do you mean like a hose clamp? is there anything in particular i can look for myself?
DanielW is offline  
    Reply With Quote Quick reply to this message
Old 11-10-2008, 03:24 PM   #4
Mr.Bergner
coffee, have some
 
Mr.Bergner's Avatar
 
Join Date: Mar 2006
Fan#: 32799
Location: Overland Park, KS
What I Drive: 2004 TW Blue ZX3

Posts: 5,966
Points 6,323, Level 51
Points: 6,323, Level: 51 Points: 6,323, Level: 51 Points: 6,323, Level: 51
Level Up 87% Completed
Level up: 87% Level up: 87% Level up: 87%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 53 Mr.Bergner Excellent Standing Member
Buy-Sell-Trade Rating: (12)
Have you considered looking into the thermostat? Here's some info on it: http://www.focushacks.com/index.php?modid=59
Mr.Bergner is offline  
    Reply With Quote Quick reply to this message
Old 11-10-2008, 09:39 PM   #5
DanielW
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 58023
Location: concord, nc
What I Drive: 2001 silver zx3

Posts: 59
FF Reputation: 1 DanielW Good Standing Member
Buy-Sell-Trade Rating: (0)
hey guys thanks for all the input. It looks like the car wasn't actually overheating. The valve cover gasket went and it was leaking oil onto the engine and it was burning off making me think i was overheating. anyway got that part replaced and everything is all better now.
DanielW is offline  
    Reply With Quote Quick reply to this message
Old 11-10-2008, 10:37 PM   #6
viney266
Focus Fanatic
 
viney266's Avatar
 
Join Date: Jun 2003
Fan#: 93
Location: westminster, maryland, MD
What I Drive: focus ztw ,zx3,mustang, motorcycles

Posts: 25,586
Points 232,586, Level 100
Points: 232,586, Level: 100 Points: 232,586, Level: 100 Points: 232,586, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 112 viney266 Excellent Standing Member viney266 Excellent Standing Member
Buy-Sell-Trade Rating: (4)
Glad its fixxed
__________________
Speed is only a matter of money; how fast do you want to go?
viney266 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SPI Timing Belt Change How to untenops SPI Performance (2000-2004) 41 12-05-2013 08:25 PM
Timing Belt Info Spanky6935 General Technical Chat 13 09-30-2011 11:54 PM
Timing belt finally went lhc_focus General Technical Chat 15 08-23-2008 05:11 PM
dodge caravan water pump silveib General Technical Chat 12 07-23-2008 08:34 PM
Timing belt where to get it done (Advice Needed) xaeniac General Technical Chat 3 07-12-2008 01:57 AM


All times are GMT -5. The time now is 06:24 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.