Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - "How To" Broken DSI Clip Fix
View Single Post
Old 08-13-2005, 10:33 PM   #1
..:: sleestak ::..
on thin air
 
..:: sleestak ::..'s Avatar
 
Join Date: Apr 2005
Fan#: 22528
Location: The Lou, MO
What I Drive: 04 Forester XTi

Posts: 3,612
Points 14,456, Level 78
Points: 14,456, Level: 78 Points: 14,456, Level: 78 Points: 14,456, Level: 78
Level Up 2% Completed
Level up: 2% Level up: 2% Level up: 2%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 80 ..:: sleestak ::.. Excellent Standing Member
Buy-Sell-Trade Rating: (15)
Post :: Fix Dat Busted DSI Clip ::

Introduction:
Okay, so I have just fallen victim to the infamous busted DSI Clip. The part costs $9 bucks and wont be available till Sept...mine is on order. Other than that, you can buy a whole new $260 manifold to get the $9 part. Ummm...no.

Thanks to a post from FORDSVTPARTS, I got some direction on how to fix this...but it had no pics. So with camera in hand I did the job to keep me happy till the new part shows up. (oh yeah, this is my first post of a new thread, and a how-to...go easy on me)..oh yeah, and my server is seeing a lot of traffic these days...so if all 7 img's dont show up, refresh.


Lets Go!

First thing is first....grab your tools and take out your intake. If it is stock, you will need to take the entire box out...open it up, take out the filter, unbolt it from the car and pull it up out. You may also want to take the MAF off the side of the box as well to help keep it out of your way.

Amongst a set of sockets and a screw driver or two, you will also need a dremmel or drill, a set of pliers/vice grips/vice.....I used a pair of needle nose pliers.



Once you have that outta the way, stand on the drivers side and look down in at the side of your manifold, right around where the Throttle Body sits...you should see the DSI "Actuator" and a dangling cable w/clip.

See how that cheap crap broke?
You should see a dot at the top of the actuator, where the post once was....the clip snaps onto the actuator right there.

Here is a pic of the broken post...I popped this out of the clip on the end of the cable using a flathead screwdriver:


and this little gem will be it's replacement:

check that it is the same thickness on the post.

Now grab that screw with a pair of pliers/vice grips/vice and grind it down with a dremmel so that the head of the screw matches the same diameter and thickness of the posts head....go a little at a time and check to make sure it fits snug, not loosely, into the clip.

Here is my grind on the screw head...I also cut it shorter so it didnt hang out too far from the side of the actuator:


If you dont have a dremmel, you should really buy one..they rule. But you can put the screw into a drill chuck and use a file to "lathe" it down.


Almost there, can you feel the suspense?!

Aight, now you gotta go back to the actuator and pilot a hole for that screw...and make sure its not a bigger hole than the the screw with wide...duh. I used a dremmel cause it fit nicely in there and I didnt have to try to wiggle that actuator out of its home.

Lol, here's a picture of my hole...



I am sure you can see where this is going....screw + hole =



If you did it right, the screw should go in snug. You can reinforce it with some epoxy if you like. But now all you have to do is rock the actuator forward a little and snap the clip over the head of the screw and you are done! Drive your car around and enjoy the satisfying sound of your dsi switching over again.

Hopefully this helps ease your frustrations while waiting for those parts to become available. Hell, you could also use this as a guide when you go to replace the part!

Happy motorin'


__________________
..:: sleestak ::..

"Our mother of blessed accelleration, dont fail us now!" -- Elwood Blues

Last edited by ..:: sleestak ::..; 08-21-2005 at 11:46 AM.
..:: sleestak ::.. is offline  
    Reply With Quote