Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - AutoCross Videos and CamCorder Mount....Done!
View Single Post
Old 07-18-2005, 06:50 PM   #3
WD40
The Librarian
 
WD40's Avatar
 
Join Date: Mar 2004
Fan#: 5157
Location: Helena, MT
What I Drive: '04 Sonic Blue - SVT 3Door

Posts: 13,116
FF Reputation: 138 WD40 Excellent Standing Member WD40 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Quote:
Originally posted by SVT4ME
I know you have a helmet on, but I'd still be a little freaked about having a "spiky" thing pointing in the general direction of my neck.
The videos played fine; and they were pretty stable considering the subject! Looks like you had fun, and the car sounds great.
Well, it is pretty soft plastic...the "spiky" thing that is.
I know it doesn't show in the pics, but that mount is about 6" behind the back of my seat.
My driver's seat is quite a bit forward from it, and I always move the passenger seat back all the way when I'm on track.
But...I think I will find a different "plug" to put in the ends of the tube.
I might have to look through some old bike parts, and maybe fit a plastic bar-end plug in there.

Glad you could see the videos!
I hope I don't get a nasty-gram from SuperMotors saying I'm using all their bandwidth,
as I plan on posting quite a few.

RE: Car sounds great;
Well, thanks again.
That's stock exhaust, ITG Pro Drop in, and "silencer" removed. That's it.
I'm rather happy with it.
WD40 is offline  
    Reply With Quote