Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Couple of Car Issues
View Single Post
Old 02-15-2014, 06:35 PM   #4
NixNox
Focus Rookie
 
Join Date: Feb 2014
Fan#: 142233
Location: Riga, Latvia
What I Drive: 1999, Green, Focus

Posts: 7
FF Reputation: 1 NixNox Good Standing Member
Buy-Sell-Trade Rating: (0)
Not steam, but stReam. I just put my vents on the window and feet, to defrost windshield.

Quote:
Originally Posted by sailor View Post
Door latches on older cars often went without lubrication, try some penetrating spray lubricant first - followed by the regular maintenance of penetrating spray grease later. Cold weather & dry, sticky lock mechanism doubles up on this "simple" problem.
What to lubricate?

And I hope that you understand correctly. When i press my key to lock car - when it works, salon light shuts down and my hazard lights flash one time. I don't have frozen locks or doors. It should be something electrical, not mechanical.

Quote:
Originally Posted by sailor View Post
Driver side speaker could be a wiring fault where the wire flex leading to the door. Before digging into wiring, look for a plug-in joint where the cables lead to the body (inside the opening between door & body). Just unplugging there, checking for corrosion & plugging back in securely may solve the problem (did on mine).
So I shold just check between body and door, for some connector? Or it's somewhere inside the door or body, but I can get to it from the space between car/body, when I open door?

Quote:
Originally Posted by sailor View Post
We don't have the electric front defrost, like the rear checking fuse & looking at wire connector the the windshield would be first checks. Careful with the connection to the Windshield - hold window side when touching the connector so it doesn't pull off the window!!
what do you mean pull off the window?

Again, sorry about my english.
NixNox is offline  
    Reply With Quote