Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Vehicle will not stay running unless I give it gas..
View Single Post
Old 07-16-2013, 12:20 PM   #9
amc49
Focus Fanatic
 
Join Date: Mar 2012
Fan#: 96610
Location: Fort Worth, TX
What I Drive: 00 wagon, 02 sedan both zetec atx

Posts: 5,569
Points 3,213, Level 35
Points: 3,213, Level: 35 Points: 3,213, Level: 35 Points: 3,213, Level: 35
Level Up 9% Completed
Level up: 9% Level up: 9% Level up: 9%
Forum Activity 60%
Activity: 60% Activity: 60% Activity: 60%
FF Reputation: 25 amc49 Great Standing Member
Buy-Sell-Trade Rating: (0)
What motor? If the zetec all you can get is the manual trans TPS, the automatic is not available. Autozone part #TPS274 is for MTX not automatic, the two parts are not compatible and will produce your troubles. Of course other things could too. The automatic one you find that looks different is for the SOHC motor. O'reilly claims automatic one but just try ordering it, a non event.

Bad TPS will screw up idle to where vehicle runs perfectly until you get down around idle, then it spits its' guts out. Have to push down pedal to keep it running. BTDT. They may be able to rig engine to idle but they cannot repeat what must happen as soon as you roll throttle on, or the PROPER increase in volts the TPS provides. The fix for ATX zetec is a new throttle body, Ford modded it fairly early and why no one makes parts for old one, they thought they couldn't sell them. You have to buy the throttle body (and a new connector since old one doesn't work, great work Ford!) to get a proper new ATX TPS. Or...........look at the stickies here for what I did to get around a $200 part. Mine did same as yours in OP but fixed it instantly.

Any mechanic worth his salt can easily measure the TPS voltage to check for the problem................like this..............

http://www.focusfanatics.com/forum/showthread.php?t=313092

Last edited by amc49; 07-16-2013 at 08:04 PM.
amc49 is offline  
    Reply With Quote