Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Vehicle will not stay running unless I give it gas..
View Single Post
Old 07-15-2013, 04:13 PM   #7
Dmusick
Focus Jr. Enthusiast
 
Join Date: Jul 2013
Fan#: 116735
Location: Houston, TX
What I Drive: 2001 Ford Focus

Posts: 27
FF Reputation: 1 Dmusick Good Standing Member
Buy-Sell-Trade Rating: (0)
When I drove the vehicle from where I bought it from 60miles away, car had little less than half a tank of gas. I put in fuel injector cleaner and ran seaform through it.. Then I drove until no gas, then filled her up with premium 93 fuel. Replaced all those parts, and car is worse.. I checked all over with no luck on vacuum leaks, went back to auto parts store to find out the TPS they sold me was a used one outta somebody's vehicle (dura last box, with a factory tps inside) so went to a different store and got the right one.. So I think? They told me up and down its for an automatic, came home and installed it.. No luck, I have to give it gas for it to start and keep giving it gas to keep it running. I googled the TPS for automatic, it looks nothing like the one that is currently on the vehicle...Wife at this point is not happy... The car is for her so she can drive to school and back, and then it's gonna be my sons first car when he turns 16 next year. So with that said THE BOSS HAS SPOKEN!! The car is at my local mechanic shop (very trustworthy guys) to do a diagnosis on it, so I can fix it myself to save money.

Sorry for my scatter brain... Yes I made sure they was no old gasket or anyone on the icv. And installed it with the gasket it came with.

Also, just for giggles. I uninstalled the TPS and stared the car to see what it would do.. Same issue!!

I will let you all know the verdict when I find out. THANK YOU ALL AGAIN FOR THE FEEDBACK
Dmusick is offline  
    Reply With Quote