Focus Fanatics - View Single Post - Struggling with an EGR code? Look here.
View Single Post
Old 05-12-2013, 04:36 PM   #1
Andrews-bad-SE
Focus Enthusiast
 
Join Date: Jun 2012
Fan#: 100389
Location: O'fallon, MO
What I Drive: 2003 Arizona Beige SE 4dr Zetec/ATX

Posts: 182
FF Reputation: 3 Andrews-bad-SE Good Standing Member
Buy-Sell-Trade Rating: (2)
Struggling with an EGR code? Look here.

I had a P0401 (EGR Insufficient Flow) code for a long, LONG time. I've appealed to the help of FF members for a year, and they've all had great ideas and really good input. Lots of great info here!

This thread is first and foremost to thank everyone who helped me along the way. I'm sure you guys know who you are. Tom, iminhell, amc49, and others... all you guys. Thanks!

Here's what was the deal:
I replaced the tube, cleaned the intake side of it, replaced the valve, replaced the DPFE, and checked the vacuum lines....

Here's the kicker... I accidentally stumbled upon the culprit when I was detailing my engine bay. Apparently the vacuum feed for the EGR solenoid (Going from the intake itself to the EGR solenoid) looks tasty to mice.

So for anyone who's struggled with an EGR problem for a long time like I have, check there before spending lots of money and time chasing gremlins!
I feel dumb, because I'm usually good at this type of thing (and have found/fixed several issues just like this on everyone else's cars but mine in the meantime).

Like I said, everyone's help from my first post up till now is appreciated to no end!

Hopefully my learning experience can help someone else.


__________________
Grumpy Cat hates your stick figure family.
[HOONIGAN]
Finally fixed the EGR!
Andrews-bad-SE is offline  
    Reply With Quote