Focus Fanatics - View Single Post - Ongoing Front End Rattle
View Single Post
Old 03-05-2013, 02:11 PM   #62
PratoN
Focus Fanatic
 
PratoN's Avatar
 
Join Date: Jul 2011
Fan#: 88058
Location: Milwaukee, WI
What I Drive: 2012 Kona Blue Ti Hatchback, DCT

Posts: 3,711
FF Reputation: 10 PratoN Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by suss6052 View Post
Which mount was "beefed" up? The rear motor mount is still very flimsy on stock job 2 2012+ builds, and even the mazda speed 3 one while initially being a bit stiffer still isn't enough to prevent wheel hop and or axle clanging when the traction control tries to fight to regain power over the throttle.

I don't like going near open throttle with the car in first gear either stationary or on a moderate roll as it tends to clang violently with the traction control on, and spin the tires with it off, at least it did with the stock 16" wheels, not sure if I've tried with the tcs off yet, but with it on it does the same basic thing.
Passenger mount, apparently.

Quote:
Perhaps this issue was addressed by some rolling changes to the hardware that have been rolled out on more recently built cars, including revised "long-shoulder rivets" in the clutch itself, to reduce chatter/vibration during launch, and new right-hand engine mounts to quell a vibration at idle. The shifter itself is revised to make it harder to overshoot "Drive" and end up in "S."
Read more.
__________________
2012 FF Ti HB Kona Blue, Built 5/24/2011, 401A + Ti Handling Package, Parking Technology Package, Winter Package, Moonroof, and MFT w/NAV at v3.6 89k miles and counting...
PratoN is online now  
    Reply With Quote