Focus Fanatics - View Single Post - This is the worst car ive ever driven in snow
View Single Post
Old 02-22-2013, 11:28 AM   #108
misfire
Moderator
 
misfire's Avatar
 
Join Date: Jan 2006
Fan#: 31379
Location: West Chester, PA
What I Drive: 2012 SEL Hatch, 2014 Mazda CX-5

Posts: 15,678
FF Reputation: 30 misfire Great Standing Member
Buy-Sell-Trade Rating: (13)
Quote:
Originally Posted by 29Tudor View Post
I just put on a set of the Continental ExtremeContact DWS also. At first I didn't want to pay that much for new tires, but when you're driving around with $500 deductible on your insurance and as much as any new car costs to fix now it started making a whole lot more sense. I sold the OEM's on CL with more than half the tread left. But now I'm seeing the results and am very happy with making the switch. I've been out in 4-5" snow with out any problem getting around. Of course you have to know how to drive in the stuff also. Saying that after living in Michigan for over 50 years and never have been stuck not even with a '58 VW.
NICE!!!

Quote:
Originally Posted by 1rkRAGE View Post
I got new PureContact w/ EcoPlus and they're fantastic in the snow as well. Combined with constantly using highest gear with selectshift, I haven't seen the Traction control go off in a while now.

During my drive in a semi-unplowed road early this morning I was doing the speed limit without any noticeable slippage. I've had no serious understeer like in the past set of tires either.
I just had a Continental rep here at the dealer last week and he was saying the PureContact's are the cats meow. lol.
__________________
Will aka Misfire
2010/2011/2012/2013 Ford Master Certified Service Advisor
2003 LX "traded in"/2010 SES "traded in"/2012 SEL Hatch "current"
misfire is online now  
    Reply With Quote