Ford Focus Forum, Ford Focus ST Forum - View Single Post - ZETEC Timing Belt Replacement
View Single Post
Old 02-21-2013, 08:34 PM   #169
defabricational
Focus Rookie
 
Join Date: Feb 2013
Fan#: 110248
Location: Huntsville, AL
What I Drive: 2002, Fire Engine Red ZX3

Posts: 1
FF Reputation: 1 defabricational Good Standing Member
Buy-Sell-Trade Rating: (0)
Nightmare after replacing the belt!

Hey everyone,

My cousin (an auto-mechanic professionally employed) and my self attempted a timing belt job on a 2002 focus ZX3 2.0L DOHC last weekend. All seemed to go smooth until the test drive. The engine would surge / stall / miss on load. If you lightly put on the gas it wouldn't miss or anything strange... half way down and things start going weird.

The Speedometer jumps all over the place... all the way up to 140MPH and back down again. Eventually it comes back to the speed you are actually traveling. The dash makes clicking noises and randomly the door open light will come on for a few seconds. We started looking for the source of the problem.

My cousin felt it must be related to the ignition somewhere so we replaced the spark plugs and wires... and guess what? It started to purr like a kitten again! But this is not the end of my woes...

The following evening I drove the car to his house to watch the walking dead... all ways good and fine until I left... When I pulled away and got onto the road ALL OF THE SYMPTOMS HAD COME BACK!

I can't figure it out. He can't figure it out. Autozone employees can't figure it out. Did we damage something on the harness while we had the engine off the side mount and on the jack/moving it up & down to get at the serpentine belt?

Any help would be greatly appreciated. This is my daily driver and my most favorite car ever... so needless to say I'm hurting.


Thanks!

-Seth
defabricational is offline  
    Reply With Quote