Focus Fanatics - View Single Post - need a diagram or pic. focus is dead
View Single Post
Old 02-15-2013, 05:09 AM   #8
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,083
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by chenize View Post
I Have 2002 ZX5 and yesterday It died getting on the freeway. Any way after I got it towed the ignition switch is dead any thing that will work with the ignition off still works, the battery is still fully charged but when you turn the key on none of the idiot lights or guages work and the brake and headlights will not come on can any body help me?
Please start your own thread. This thread is about physical engine damage due to a broken motor mount- not any other problem. His car will start, yours will not, so the problems are different.

Go to this link:
General Technical Chat
Before you scroll down, in the lower left hand corner you will see a yellow button labeled "New Thread", click that, and describe your problem with as much detail as you have, your engine, year model car, transmission, and mileage. Then we can help you. Thanks for posting!
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline