Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2002 Zetec Engine Ticking/ Misfiring?
View Single Post
Old 02-13-2013, 06:21 AM   #5
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,268
Points 27,528, Level 98
Points: 27,528, Level: 98 Points: 27,528, Level: 98 Points: 27,528, Level: 98
Level Up 18% Completed
Level up: 18% Level up: 18% Level up: 18%
Forum Activity 13%
Activity: 13% Activity: 13% Activity: 13%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by vermen1993 View Post
I honestly don't know what could be causing it, so I'm gonna replace all the plugs anyways, they're oldish. And especially since it happened right after I got snow in there, everything points to that. It was really bad when it first happened, but now it's gotten better, but has stopped getting better and kind of plateau'd.
That would be plugs and plug wires. Don't forget to put anti-seize on the plugs, and I would not suggest Bosch plugs. Stick with Motorcraft, Autolite, or Champion.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote