Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2008 focus sub and amp install
View Single Post
Old 02-09-2013, 09:31 PM   #1
Kurtsmith2013
Focus Jr. Enthusiast
 
Join Date: Jan 2013
Fan#: 108102
Location: Denton, United Kingdom
What I Drive: 08 focus titanium grey

Posts: 38
FF Reputation: 1 Kurtsmith2013 Good Standing Member
Buy-Sell-Trade Rating: (0)
2008 focus sub and amp install

so i decided to hook up a sub and amp in my focus. i ran the power wire from my battery (fused) to my power in my amp, i ran my remote wire from the amp to a fuse under my glovebox (fuse tap) and my ground i ran from amp under the carpet to a metal seat belt holder thing, i had the stock sony head unit, so i bought a LOC converter and tapped into my rear speaker wires.(connected to amp. my sub came on and i listened to it for 2minutes, then switched it off and just made sure my wires were tooked away properly, i turn my car back on and no sound from the sub. so i checked over all wires and noticed the fuse in power wire had blown, so i decided to upgrade my stereo to the new sony/sat nav/dvd. i installed that and it had lots of extras on the back, rear left/rear right so i connected my rca cables to that to the amp, left my remote wire where it was as i wasnt sure if the new one had a remote wire built in? still no noise from the sub but it pops when i turn the stereo on then the power fuse blows, i had a 30amp fuse in the power fuse and 30 amp fuse in the amp itself, i swapped amps to see if the amp was toast, my other amp i had 2 30amp fuses in and it still blows the fuse in my power cable? do i need a 50amp fuse in my power fuse? and why doesnt my sub work? the sub isnt blown or anything because i have checked? thanks in advance.


Kurtsmith2013 is offline  
    Reply With Quote