Focus Fanatics - View Single Post - High Idle Saga Continues...
View Single Post
Old 01-25-2013, 11:53 AM   #14
rycodge
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108520
Location: Portland, OR
What I Drive: 2003 Blue ZX3

Posts: 19
FF Reputation: 1 rycodge Good Standing Member
Buy-Sell-Trade Rating: (0)
Mystery saga continues with a major update!

So this car had a previous front end collision and some repair work was done to the wiring harness that runs through the front part of the frame. My right hi beam light wasn't working and traced the issue to the wiring harness. The incompetent idiots that "professionally repaired" the car swapped the green-orange hi beam power lead with the green-orange lead that goes to the AC pressure switch!! It looks like the pressure switch wiring was also severed and rewired together. My hi beams work as expected now...

Here's the kicker. I'm wondering if my AC pressure switch / wiring cluster is telling my ECU to crank up the idle even when my AC is "off". I am under the impression that my idle control valve is working just fine, it's just being told to raise the idle when it shouldn't. Hence, when it's unplugged the car runs and idles normally.

Am I correct that the power steering switch and one or both of the AC switches can make the ECU crank up the idle? Can I bypass the switches and hotwire the car quickly to make it think the AC is truly off (It's winter in oregon, no need for AC!).

Also, if anyone has a detailed wiring diagram of the AC pressure switch / wiring that would help a ton! The haynes diagram is a bit lacking in this area.
rycodge is offline  
    Reply With Quote