Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2010 Focus - Brake and Engine Trouble
View Single Post
Old 01-22-2013, 07:40 PM   #2
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,272
Points 27,546, Level 98
Points: 27,546, Level: 98 Points: 27,546, Level: 98 Points: 27,546, Level: 98
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 13%
Activity: 13% Activity: 13% Activity: 13%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
You're feeling quite a few things through the brakes, I think. First off, the tires probably have flat spots from sitting. You'd feel some shaking while driving down the road. You might even have bad tires, but for now, let's just assume it's flat spots.

If brakes sit for a long time, they will build up some rust residue, and it will cause some vibration in the pedal for a short time- a few days. There is always the possibility that the rotors are warped. That's not uncommon. This can happen if someone does some hard braking. You can also have problems from old pads. Old pads that sit out in the weather don't wear right, and can be problematic sometimes.

As far as the stalling engine goes, first off, we need to know which transmission you have. Either a manual or automatic. The problem could be that there hasn't been a "tune-up" done to the car in a long time. It could have some bad gas in it- ethanol blended gasoline will only survive for a month before it separates and that doesn't make for a happy engine until you burn it all up. There's nothing you can do to fix this but run a few tanks through the car. It could be other things also. The IACV sometimes doesn't act correctly after a car has been sitting for a while. The valve can stick, and not maintain idle. My guess would be fuel though. Dealers would be wise to fill-er-up before leaving the lot, and that would dilute bad fuel so that the car would act better until the bad fuel was used up. It could also be something as simple as a loose battery connection. Unless the mileage is up around 100k, I wouldn't think that the alternator was the problem.

It's hard to say for sure without being there to diagnose the problem. Keep taking it back and they will fix everything. 2010 Focis are a lot like my 05, and I didn't have to do anything to my 05 except what you'd expect- like brakes, struts, oil changes and so forth over 150k miles. The alternator went out around 120k, which is not abnormal for any vehicle. The accessory belt hadn't broken, but I changed it when I did the alternator- around 100k is about the life of an accessory belt.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote