Focus Fanatics - View Single Post - I'm at my wits' end!
View Single Post
Old 01-22-2013, 05:04 AM   #7
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,089
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
The TPS is your problem. You must purchase the re-designed model with the TB or you will have running problems. You can check www.rockauto.com, and they had some made by Doorman IIRC, or you can check with Village Ford, our OEM parts supplier who gives us major discounts on Ford parts.

You won't have to worry about installing the TPS wrong because it comes installed on the TB. You are correct though, the TPS must be fitted to the shaft, not the screw holes. Typically it is tilted slightly towards the air intake, and it should slide on flush without force. If it doesn't fit flush, then you don't have it lined up properly. Then you rotate it back to line the screw holes up.

edit: Rock Auto doesn't sell the TB you need. You might end up having to go to a junkyard, but there is no telling if the part you get is working or not.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote