Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - High Idle Saga Continues...
View Single Post
Old 01-21-2013, 12:14 AM   #1
rycodge
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108520
Location: Portland, OR
What I Drive: 2003 Blue ZX3

Posts: 19
FF Reputation: 1 rycodge Good Standing Member
Buy-Sell-Trade Rating: (0)
High Idle Saga Continues...

Symptoms: Car will idle at 2200 rpm while moving down the road. If stopped the idle ticks down to 1700, then it will finally come down to 1000 rpm after about 10 seconds. When revving the engine up, the rpm's drop far too slowly. When depressing the clutch, usually the rpm's will shoot up about 200-300 then start their slow decent. The car is running great after a major tune up. This idle thing is starting to hang me up though.

I've replaced my IAC valve twice with no luck. I've replaced my TPS sensor just to check and no luck. I've gone through the idle learn procedure a few times. I do not believe I have a vacuum leak. I've checked brake booster lines and PCV valve lines and they are good, other lines I've looked at look good. I've sprayed starter fluid all over the intake and common vacuum lines without any noticeable change in idle speed.

When I disconnect the IAC valve the car runs great! Idle is around 800 rpm and the throttle response is good and the rpm's will drop right down to 800 rpm after letting up on the throttle.

I'm about to break down and go for a smoke test from a local garage. Any ideas before I sink more $$ into this project?

Do autozone "cheaper" IAC valves just suck that badly that they don't work properly?


rycodge is offline  
    Reply With Quote