Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - SVT with sudden rough idle, power loss
View Single Post
Old 01-20-2013, 07:47 PM   #60
swansong
Focus Addict
 
swansong's Avatar
 
Join Date: Feb 2011
Fan#: 83576
Location: Appleton, WI
What I Drive: 2008 Saab 9-3 Aero SportCombi XWD

Posts: 1,497
Points 2,255, Level 28
Points: 2,255, Level: 28 Points: 2,255, Level: 28 Points: 2,255, Level: 28
Level Up 70% Completed
Level up: 70% Level up: 70% Level up: 70%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 12 swansong Great Standing Member
Buy-Sell-Trade Rating: (4)
I've been pounding the hell out of the search feature (pro-tip to those using search, I actually have better success with Google: search site:focusfanatics.com *problem here*)

Sounds like it might just be the plugs crapping out from the valve cover gasket leaking. I've got the gasket and Motorcraft SP-463's on order at my FLAPS (of course, no one stocks SVT parts), but I might pick up a close-enough set of plugs tonight at Wally World just to see if that's what it is.

From reading threads, CPS should always throw a code when it goes out, so I'm ruling that out for now.

Still could be a fuel/injector issue, but plugs are much cheaper so I'll try those first.
__________________
Mine: 2008 Saab 9-3 Aero SportCombi XWD: 92k, Black, Manual, JZW Stage 1. 320hp/400tq.
Gone: 2002 SVT, #1654

Hers: 2010 Focus SES: 84k, Ebony, Auto, Moon and Tune
swansong is online now  
    Reply With Quote