Ford Focus Forum, Ford Focus ST Forum - View Single Post - SVT with sudden rough idle, power loss
View Single Post
Old 01-18-2013, 05:39 PM   #55
6SPD_soul
Focus Addict
 
6SPD_soul's Avatar
 
Join Date: Feb 2008
Fan#: 53637
Location: Soldiers Grove, WI
What I Drive: 2003 Comp Orange EAP SVT

Posts: 1,468
Points 2,489, Level 30
Points: 2,489, Level: 30 Points: 2,489, Level: 30 Points: 2,489, Level: 30
Level Up 26% Completed
Level up: 26% Level up: 26% Level up: 26%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 24 6SPD_soul Great Standing Member
Buy-Sell-Trade Rating: (1)
Buddy4679, I had a bad vacuum leak that caused the symptoms you described, it turns out a nipple on the back of intake manifold right after the TB had broken off, it's a port for the EVAP system and basically left a 1/4" hole in the intake manifold. I have no idea how or why mine broke but I'd be surprised if my car was the only one with this problem.

swansong, what did the shop tell you? They should have done a spark test, they're straight up incompotent if they didn't, it takes like 3 minutes. They should have also already done the compression testing to verify that timing was still right.

And BTW, if you do the compression tests, don't neccessarily condemn anything if you get compression but it's lower than 100 psi. My car does between 75-80, which concerned me, and then I did leakdown testing and those results were good, 5% loss on 3 cylinders and about 10% on one. Plus the engine runs fantastic, so I'm kind of not worried about it anymore. Also there's something weird with my starter and it kicks out after a few seconds of cranking and that makes compression testing kind of a pain and maybe inconclusive in my case. I've heard that VCT somehow causes misleading compression test #s but I'm not positive on that.
6SPD_soul is offline  
    Reply With Quote