Focus Fanatics - View Single Post - SVT with sudden rough idle, power loss
View Single Post
Old 01-16-2013, 09:11 AM   #13
swansong
Focus Addict
 
swansong's Avatar
 
Join Date: Feb 2011
Fan#: 83576
Location: Appleton, WI
What I Drive: 2008 Saab 9-3 Aero SportCombi XWD

Posts: 1,458
FF Reputation: 10 swansong Great Standing Member
Buy-Sell-Trade Rating: (4)
Fuel filter and pump replaced. Fuel pressure was abysmal before, it's optimal now. Filter was likely original (135k miles!) and pump was full of crud. Car will start now, and may run well for 5-10 seconds, then falls on its face and stalls. Seems to do better with throttle applied. (This is what shop told me, haven't driven it myself.)

They're stumped, and I told them not to throw parts at it, I'll just take it home and try to figure it out myself. I think it's drivable at this point.

Still to check:
  • Vacuum leaks, I checked the easy ones, haven't gotten to all of them yet. Shop wanted $80 to do a smoke test. Eff that.
  • Coil pack pigtail wiring.
  • MAF sensor. Don't want to replace it if I don't have to, they're surprisingly expensive.
  • Dump some Heet in the tank, possibly due to water in gas.
  • Try to return to stock tune, reset ECU by removing negative cable. Perhaps ECU is confused with a properly operating fuel system?
  • Send a datalog out to Tom, maybe he can see something I can't.
Any other suggestions..?
__________________
Mine: 2008 Saab 9-3 Aero SportCombi XWD: 84k, Black, MANUAL
Gone: 2002 SVT, #1654

Hers: 2010 Focus SES: 73k, Ebony, Auto, Moon and Tune
swansong is online now  
    Reply With Quote