Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Install on 2013 base model? Need some verification.
View Single Post
Old 01-10-2013, 10:29 PM   #1
BumpandThump
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108350
Location: Baltimore, MD
What I Drive: 2013,gray/charcoal black, S manual

Posts: 4
FF Reputation: 1 BumpandThump Good Standing Member
Buy-Sell-Trade Rating: (0)
Install on 2013 base model? Need some verification.

Whats up everybody? Just got my brand new 2013 ford focus sedan s 5 speed manual transmission and although the speakers sound great, im ready for some bass!
I am attempting to install an amp, and 1 twelve inch sub to add some depth, using a line out converter because I do not feel like messing with the factory HU.

Now heres what I have.

12 in sub.
Kenwood Kac-8105d amp
Amp installation kit

My question is what else do I need?
I know I have to get a Loc, but what about little things. To splice the speaker wire can I just wrap them or do I need those wire taps? I have never done an audio install before but I am a perfectionist and want this done well (As well as it can be without professional install).

Also where should I run my remote wire to? I do not want to mess up the fuse box or anything, or steal power from something else, so im thinking about doing a switch. I read on here about somebody else using a manual power switch for the amp. To do this, what would I need?
Am I missing anything? Y adapters? Other adapters? Grommets and shit?
Not really sure what im getting into 0_0


BumpandThump is offline  
    Reply With Quote