Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Exhaust/emissions problem or fuel pump/filter?
View Single Post
Old 01-07-2013, 09:18 PM   #1
butchhuskey
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108112
Location: Mpls, MN
What I Drive: 2001, black, ZX3

Posts: 2
FF Reputation: 1 butchhuskey Good Standing Member
Buy-Sell-Trade Rating: (0)
Exhaust/emissions problem or fuel pump/filter?

So my '01 Focus ZX3 started showing the common Focus problem of driving rough, a lot of jerking and hesitating and it felt like inconsistent power delivery. It would idle all day long just fine so I i figured it wasn't a fuel pump, the problem was leaving from a stop the motor would start to die and then the ride would be jerky.

Going through the forums the DPFE sensor seemed like a good place to start, especially since it was pretty cheap and easy to replace. After putting in a new one the problem went away completely. For 20 minutes. It was fine on my way to work but I had a couple times on my drive home where it hesitated again. Now 2 days later it barely will even start, it idles really rough and loud, which wasn't an original symptom, and dies immediately after giving it some gas. This seems more like a fuel issue, but why did the DPFE change help, and why for just a short while?

Just a little more info, my CEL came on when the car first started hesitating, it didn't go out when the sensor was replaced or after disconnecting the battery, but I didn't disconnect the battery until the new problems started. I don't have a code, and at this point I think I would have to tow it somewhere to be diagnosed, I'd love to try a few things though before I pay for a tow and have a garage take over though.


butchhuskey is offline  
    Reply With Quote