Ford Focus Forum, Ford Focus ST Forum - View Single Post - Vibration
Thread: Vibration
View Single Post
Old 01-07-2013, 05:02 PM   #13
amc49
Focus Fanatic
 
Join Date: Mar 2012
Fan#: 96610
Location: Fort Worth, TX
What I Drive: 00 wagon, 02 sedan both zetec atx

Posts: 4,891
Points 2,845, Level 32
Points: 2,845, Level: 32 Points: 2,845, Level: 32 Points: 2,845, Level: 32
Level Up 64% Completed
Level up: 64% Level up: 64% Level up: 64%
Forum Activity 85%
Activity: 85% Activity: 85% Activity: 85%
FF Reputation: 23 amc49 Great Standing Member
Buy-Sell-Trade Rating: (0)
Yes, sometimes they break like that, I always carefully run my hand around the bottom to feel it. Many others break inside though to not be obvious, the metering plate either comes loose or breaks. The aftermarket commonly uses a rivet to fasten it, that rivet comes loose and mount quits absorbing vibration. There is no need to determine if it is broken, only a deaf person cannot tell as it will rattle like hel-. Irrelevant again as you change that one first anyway first anyway........

' He's got no choice but to replace all 3 - and cross his fingers and hope that solves the problem.'

Well, yeah, if you don't read I guess you'd have to do that. I posted the most likely one to go, and ways to separate all three from each other, ADD is not my fault...........just holding the engine in the bay is by far not all these mounts do. The vibration is FELT, past hearing when bad enough, no stereo even $500 one is going to mask that.

I have bought Anchor mounts since the eighties, they have the market choked apparently. They VERY often are substandard even when brand new, the pass side ones have the top plate lightly pressed into place to let mount explode in as little as 2-3 months. Garbage.
amc49 is online now  
    Reply With Quote