Ford Focus Forum, Ford Focus ST Forum - View Single Post - Need help identifying problem with engine.
View Single Post
Old 12-21-2012, 11:56 PM   #1
blendededge
Focus Rookie
 
Join Date: Mar 2012
Fan#: 96969
Location: Pompano Beach, FL
What I Drive: 2002 Pitch Black SVT

Posts: 3
FF Reputation: 1 blendededge Good Standing Member
Buy-Sell-Trade Rating: (0)
Red face Need help identifying problem with engine.

Greetings fellow fanatics,

I hope you guys will be able to shed some light on a problem with my SVT. Car was running fine, then the next morning it wouldn't start. It would crank and felt like it was going to start but didn't. Was not a battery issue, got a brand new one a few months back. Then I had a "great" idea, I started to turn the ignition to see it the fuel pump was priming, I couldn't hear it as loud as usual. I must have turned the key maybe 10 times, then I decided to try to turn on the car. BOOOOOM!!!!! I almost crapped my pants and smoke everywhere!!

The intake manifold blew up. I guess that answered my question about the fuel pump:( $900 bucks later, intake manifold was replaced. Car starts now, but is running hot! After a few minutes idling the exhaust heads start to glow a little red. There was no code thrown by the computer and the mechanic checked the timing and confirmed it was correct. I think he mentioned compression was low across all cylinders, but i don't have the exact info on that yet. Will get this info tomorrow...

He doesn't seem to know what the problem could be. Tomorrow I'll be going to the shop so I'd like to give the mechanic some of your theories on this. I appreciate any help.

Was running Tom's tune, but switched back to factory after the explosion. No mods other than hi flow cat and 67mm throtle body from cfm.


blendededge is offline  
    Reply With Quote