Ford Focus Forum, Ford Focus ST Forum - View Single Post - HELP!!!!! Turn over, but engine wont start!!!!!
View Single Post
Old 12-14-2012, 05:16 PM   #1
jlawlax1344
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99464
Location: Salisbury, MD
What I Drive: 2003-CD Silver-SPI-5spd

Posts: 68
Points 191, Level 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jlawlax1344 Good Standing Member
Buy-Sell-Trade Rating: (1)
Exclamation HELP!!!!! Turn over, but engine wont start!!!!!

I was driving my focus earlier today and it would start to sputter on me a lot, and tried to cut out several times. It never did but once i parked it the check engine light came on and i turned the car off. Later when i went to head to work, i tried to start my car and it would turn over, and try to start, but will not fully start.

I have recently replaced the spark plugs, wires, distributer cap, battery, and starter.
I also recently had the alternator checked and it was working perfectly fine. When i turn it to AUX all my lights and accessories come on and work, and the car will turn over, but wont start.

I think this could be a bad fuel pump or pump relay, but I am pretty sure it is fuel system related.

ANY help or input would be greatly appreciated!


__________________
2 12" rockford fosgate subs,1500w Hifonics amp, throttle spacer, performance chip, FSWerks 2.5" race exhaust, custom CAI w/Spectre 10.5x6 filter Blue leds all around pulsating in the trunk, smoked taillights and turn signals
jlawlax1344 is offline  
    Reply With Quote