Ford Focus Forum, Ford Focus ST Forum - View Single Post - JRSC - hesitation/stumbling of engine at low rpm
View Single Post
Old 12-10-2012, 09:39 PM   #1
mj22
Focus Jr. Enthusiast
 
Join Date: Feb 2006
Fan#: 32067
Location: australia
What I Drive: 2003 silver 2.0. zetec

Posts: 30
FF Reputation: 1 mj22 Good Standing Member
Buy-Sell-Trade Rating: (0)
JRSC - hesitation/stumbling of engine at low rpm

Hi Guys,

Some of you may recall a month or so ago I had a post up about my car after having just installed the JRSC on my zetec and I wasn't able to get it to idle. It turned out this was all tune related.

The good news is the car is now driving, and has definately seen a decent improvement in how it goes.

My problem is with the JRSC and the new tune, the car has a hesitation or stumbling type problem from 1000 - 2200 rpm bit it is particularly noticeable around 1800 - 2200 rpm as this is cruising rpm in 4th and 5th gear.

Basically what happens is as I apply the throttle the car does begin to increase rpm however the rpm does not increase smoothly, as described above it has a hesitation about it. Once above 2200 rpm the problem disappears and the car revs very happily to 7k rpm without any hesitation.

Some notes about the problem:

It feels alot like an electrical/ignition problem.

I have changed through 3 sets of spark plugs:

- Motorcraft copper spark plugs (1 stage cooler)
- Denso iridiums, standard temp
- Bosch platinums, standard temp

When using the denso and bosch spark plugs the problem is reduced however the hesitation is still there.

The hesitation is much worse when the car is cold and at times it even seems like it gets worse the longer I have been driving the car in stop start traffic (this
is likely a mental thing as it all just gets more and more frustrating).

The problem is more apparent when the load on the engine is increased. ie. driving up a hill.

The coil and spark plug wires were replaced 12 months ago with an uprated MSD kit from CFM.

Finally, as far as I could tell from driving the car there were no problems prior to the JRSC install.

Can anyone advise if this appears to be an ignition related problem or tuning problem and if so could they offer some advice as to a solution?

Thanks,

Mike


mj22 is offline  
    Reply With Quote