Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - wierd problem, please help
View Single Post
Old 12-09-2012, 09:34 PM   #3
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,275
Points 27,572, Level 98
Points: 27,572, Level: 98 Points: 27,572, Level: 98 Points: 27,572, Level: 98
Level Up 23% Completed
Level up: 23% Level up: 23% Level up: 23%
Forum Activity 11%
Activity: 11% Activity: 11% Activity: 11%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
UH, typically running hot on the highway is a sign of a stuck thermostat- regardless of what they told you. Check the fluid level though. Sometimes these new systems are harder to fill than you think, so make sure you have enough coolant in there. Make sure you put the right kind of coolant in there if you add some. You'll have either gold or red, unless they cheaped you out with green. Whatever it is, it's never right to use Dexcool, and match the color if you have to add some.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote