Focus Fanatics - View Single Post - battery light
Thread: battery light
View Single Post
Old 12-09-2012, 02:12 AM   #14
Reefmonster
Focus Jr. Enthusiast
 
Join Date: Jul 2011
Fan#: 88330
Location: Perris, CA
What I Drive: 2001 Green Focus SE Wagon

Posts: 43
FF Reputation: 1 Reefmonster Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Eiron View Post
Make sure your battery cables are all solid/intact, especially at the battery clamps. If you have broken wire strands at the clamps then that could be shortening the life of both the alternator & the battery. This happened on our '02 Focus wagon (went thru 2 batteries & 2 alts) & was only fixed after rebuilding the positive cable's battery clamp.

The alt-to-starter cable could also be a candidate for problems, but that cable doesn't usually see the amount of disconnecting that the battery cables do, so it's less likely to be a problem.
I have an 01 wagon and I'm getting this now. The Alternator went bad and then the battery so I replaced both, but now the light keeps coming on and it's getting annoying. Any ideas other than those stated? I took it to Orielly and...Alternator passes, battery passes, both are new within a week. This is killing me! Could it be a bad belt or bad tensioner? When I rev the engine it goes off Sometimes...Frustrating!

Thanks in advance!
__________________
'The path of Least Resistance' is what makes Rivers and Men Crooked!
-- Ezra Taft Benson
Reefmonster is offline  
    Reply With Quote