Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Unresponsive Engine
View Single Post
Old 12-08-2012, 04:01 PM   #1
SuperSandra
Focus Rookie
 
SuperSandra's Avatar
 
Join Date: Dec 2012
Fan#: 107102
Location: Brick, NJ
What I Drive: 2012 Sterling Grey Focus SE

Posts: 18
FF Reputation: 1 SuperSandra Good Standing Member
Buy-Sell-Trade Rating: (0)
Unresponsive Engine

Hi all, I've been lurking the forums for a while now but finally just signed up

I leased a 2012 Focus SE because that was my only financial option but plan on buying it. However, I was driving to work this morning and about halfway down the parkway I noticed my speed drop from 80 to 70. Pressing the gas pedal didn't do anything. I was panicking so I can't remember if the rpm's were going up or down but I do remember that the engine was definitely not responsive. No noise, nothing. It was like I wasn't pressing the pedal at all.

I pulled over, turned it off, checked under the hood for anything funny (I'm a seventeen year old girl with her first car so I probably wouldn't have noticed anything), and started it back up and it ran fine.

A friend of mine who is a mechanic says that I probably just hit a puddle and got something in the engine wet. I'm worried because about a week ago I took off the cover of the air filter just to give my car some nice sound when I rev. Could that be the problem? Should I put the lid back on? I made a service appointment but if it's something as silly as that I'll just cancel it and keep the lid.




SuperSandra is offline  
    Reply With Quote