Ford Focus Forum, Ford Focus ST Forum - View Single Post - Engine or Trans slip or sputter?
View Single Post
Old 12-06-2012, 08:09 AM   #1
SilentSamurai
Focus Enthusiast
 
SilentSamurai's Avatar
 
Join Date: Nov 2012
Fan#: 105928
Location: Orange County, CA
What I Drive: 2012 Oxford White Focus SE

Posts: 72
FF Reputation: 1 SilentSamurai Good Standing Member
Buy-Sell-Trade Rating: (0)
Engine or Trans slip or sputter?

Good Morning,

First of all I have the Automatic SE hatchback

I really hate having to start a new thread for this but I honestly don't know the term for what happened to my car this morning while getting on the freeway. So I don't know how to search for it.

I was getting on the freeway this morning and some nice folks decided to block me into the slow lane so i had to give it some umph! to speed up and around them and get into the faster lanes. in the process (probably 4th + gear) it felt like it completely lost power, power came back, lost it again, and then came back once more.(within 1-3 seconds it did this) So I let off the throttle from almost full throttle and cruised into the 70-75mph that everyone else was doing. (Wasn't racing it or being too hard - just trying to get over and around slower cars)

Any input? After I was at the speed limit, I even tried it again. Slowing down to 50-55, and giving it some full throttle back up to 75, and it wasn't a problem. Just seems like once you're going from 25-30 to full throttle...is it slipping?

Thanks,
Adam


SilentSamurai is offline  
    Reply With Quote