Ford Focus Forum, Ford Focus ST Forum - View Single Post - amp/speakers or new HU
View Single Post
Old 12-05-2012, 11:10 PM   #12
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,377
Points 6,210, Level 51
Points: 6,210, Level: 51 Points: 6,210, Level: 51 Points: 6,210, Level: 51
Level Up 30% Completed
Level up: 30% Level up: 30% Level up: 30%
Forum Activity 8%
Activity: 8% Activity: 8% Activity: 8%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (22)
Quote:
Originally Posted by austinpetemo View Post
Ok so when I pulled the head unit forward I accidentally pulled out a connection in the back. Redid everything and it came on. Up next will be a better HU and thicker power/ground. I'm thinking 2awg to a distributor and then 4awg to each amp will work. When I get a better sub amp I still won't be running more 600w through it. I think what I have right now is like 6-8 and prolly not true copper. I made sure to get true 14awg 99.9% copper wire for my components but I just used power cable I already had installed.
You cannot go wrong here, http://www.knukonceptz.com/

Easy on the wallet as well
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote