Focus Fanatics - View Single Post - Rough Idle only when the A/C is on
View Single Post
Old 11-17-2012, 08:17 PM  
mikebontoft
Toxx
 
mikebontoft's Avatar
 
Join Date: Aug 2008
Fan#: 58647
Location: SLC, UT
What I Drive: 5.9L Grand Cherokee ZJ

Posts: 25,767
FF Reputation: 76 mikebontoft Excellent Standing Member
Buy-Sell-Trade Rating: (3)
I'm not aware how the focus controls the idle up function when the compressor is engaged... I'm guessing probably just the pressure switch on the AC which would mean the Idle Air Control (IAC) valve is not not operating correctly.

It runs worse warmed up because when the engine is cold it has a higher idle anyway. How the idle is controlled at start up I don't know... maybe it doesn't use the IAC valve, but it should. If it does, then the IAC is operating correctly but perhaps the computer is not receiving the signal to adjust the idle... There is only one pressure switch according to the diagram I have, and it's a dual pressure switch. The AC engages (correct?) so there shouldn't be a problem with the wiring to it. There appears to be only two wires to the IAC as well, power and the ground which is controlled by the computer.

The engine runs fine when it's cold and when the AC is off, correct?
__________________
SR #127 | '02 Focus SE "Foci" (5.0 RWD - parting) | '90 Mazda 626 GT "Greenie" (2.2L turbo T3/T4 rebuild-sold) | '75 BMW 2002 "Carby" (resto-mod racecar) | '75 BMW 2002 (donor -sold) | '98 Jeep Grand Cherokee 5.9L (lifted and fast) | '99 BMW 328is (alt. daily).
Moderating General Chat Lounge, General Technical Chat, Ford Focus & General Car Chat, and Rocky Mountain Fanatics
mikebontoft is online now  
Reply With Quote