Focus Fanatics - View Single Post - NO indicator for winshield wiper fluid
View Single Post
Old 11-15-2012, 08:23 PM   #170
Some Guy From NY
Focus Enthusiast
 
Some Guy From NY's Avatar
 
Join Date: Jul 2012
Fan#: 101517
Location: Brooklyn, NY
What I Drive: 2012 SGM Focus SEL sedan DCT

Posts: 493
FF Reputation: 3 Some Guy From NY Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Merrigan View Post
The Focus is the first car I've ever driven with a warning for low or no fluid. I live in northern Alberta now. Plenty of and and salt on the high ways. And I lived and drove in Newfoundland for 5 years before that. I think they came up with the idea of putting salt on the road in Newfoundland, if not perfected it. It's not a big deal to throw a jug of wash fluid in the trunk and if you run out pull over and top up. That's what I always did.

That being said. A new or pretty new car should work right. If it's something as simple as the indicator isn't working correctly bring it to the dealership and tell them to fix the damn thing. Simple as that.

Sent from your mom's house.
Of course. This is the first car I have ever had to have this indicator, never even heard of a car with one before. It really is no big deal, but like you said- It is a NEW car and ALL the features it has should work and work correctly. No matter how "small" or "insiginifcant" they may be.
__________________
Mods: Drop in K&N filter, Steeda RSB, MS3 RMM, Remote start, Llumar tint, Ti engine cover, Husky floor mats, OEM splash guards
Some Guy From NY is offline  
    Reply With Quote