Focus Fanatics - View Single Post - Thougts on NAPA water pump and Thermostat housing?
View Single Post
Old 11-14-2012, 10:13 AM   #6
G Ford Fan
Focus Enthusiast
 
Join Date: Nov 2010
Fan#: 80771
Location: Southern, PA
What I Drive: 2000 Ford Focus Wagon, SE, Silver.

Posts: 157
FF Reputation: 0 G Ford Fan Newbie
Buy-Sell-Trade Rating: (0)
excellent, thanks so much gents!

That was my game plan, I think I'm going to hold off on the housing as I don't think it's leaking there, I think it's the T-stat cover to housing seal that's leaking and I did not put any RTV on that before when I had the T-stat out prior.

I will do so this time and see how it is.

The ater pump seems a bit challenging, but I'm going to give it a go this weekend hopefully.

It's currently "marking it's territory" HAHAHA. (not severe, a small spot each time i stop and i checked the fluid level this morning and it's still at the full mark)

I was also going to put a very thin bead of blue RTV on the water pump o-ring/seal as well, not much, enough that you can still see through it just for good measure.

I also think/agree it's HIGHLY important to let the RTV dry overnight before adding water. When I was younger I never did that and sometimes had leaks. I started allowing it to dry first a few years ago and have not had any problems.

One last thing, do you all think I should just spend the $100 and get a new ford water pump or try the $50.00 NAPA job. I'm tempted to just buy the Ford and be done with it......but if the NAPA ones are good quality and will last for ahwile, I'd rather save the $50.00. I'm just concerned with fitment, as sometimes the aftermarket stuff is just a bit off and that can cause leakage problems down the line.
G Ford Fan is offline  
    Reply With Quote